Bug 1395473 - SELinux is preventing gst-plugin-scan from 'getattr' accesses on the netlink_kobject_uevent_socket Unknown.
Summary: SELinux is preventing gst-plugin-scan from 'getattr' accesses on the netlink_...
Keywords:
Status: CLOSED DUPLICATE of bug 1410942
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:039c6d10b083282d4c1a5f434a7...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-16 01:10 UTC by striker.pena
Modified: 2017-01-08 20:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-08 20:09:37 UTC
Type: ---


Attachments (Terms of Use)

Description striker.pena 2016-11-16 01:10:27 UTC
Description of problem:
SELinux is preventing gst-plugin-scan from 'getattr' accesses on the netlink_kobject_uevent_socket Unknown.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gst-plugin-scan should be allowed getattr access on the Unknown netlink_kobject_uevent_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gst-plugin-scan' --raw | audit2allow -M my-gstpluginscan
# semodule -X 300 -i my-gstpluginscan.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Objects                Unknown [ netlink_kobject_uevent_socket ]
Source                        gst-plugin-scan
Source Path                   gst-plugin-scan
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-191.20.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.8.6-201.fc24.x86_64 #1 SMP Thu
                              Nov 3 14:38:57 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-11-15 17:08:38 PST
Last Seen                     2016-11-15 17:08:38 PST
Local ID                      6cafd9ab-287a-4d3a-af1e-0aff799573dc

Raw Audit Messages
type=AVC msg=audit(1479258518.833:280): avc:  denied  { getattr } for  pid=3319 comm="gst-plugin-scan" scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tclass=netlink_kobject_uevent_socket permissive=1


Hash: gst-plugin-scan,thumb_t,thumb_t,netlink_kobject_uevent_socket,getattr

Version-Release number of selected component:
selinux-policy-3.13.1-191.20.fc24.noarch

Additional info:
reporter:       libreport-2.7.2
hashmarkername: setroubleshoot
kernel:         4.8.6-201.fc24.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2017-01-08 20:09:37 UTC

*** This bug has been marked as a duplicate of bug 1410942 ***


Note You need to log in before you can comment on or make changes to this bug.