Bug 139548 - automount using LDAP
automount using LDAP
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 12:04 EST by John S. Monaco
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.1.3-130
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 12:37:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John S. Monaco 2004-11-16 12:04:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040913

Description of problem:
    While using LDAP automount tables, the automount entries which
included upper-cased letters needed to be handled a certain way in
order to accommodate our Solaris 8 and Red Hat 7.3 clients. However,
while using RHEL 3.0 WS, these accommodations are not working.

-----------------------------------------------------------------------
dn: cn=%T%I_apps, nisMapName=auto_home, ou=foo.bar
nismapname: auto_home
objectClass: top
objectClass: nisobject
nismapentry: foo.bar.ti.com:/vol/vol6/TI_apps
cn: %T%I_apps
cn: TI_apps
-----------------------------------------------------------------------

    The "%" characters are used to escape the upper-case letters
within the Solaris 8 server's LDAP maps. If the characters aren't
escaped, then they are treated as lower-case. The "cn: %T%I_apps" is
used for Solaris 8 clients, and the "cn: TI_apps" entry is for the Red
Hat 7.3 clients.

    If you tried the following on a Red Hat 7.3 client, it works like
this:
---------------------------------------------------------------------
# cd /home/TI_apps
# pwd
/home/TI_apps
# df -k .
Filesystem           1k-blocks      Used Available Use% Mounted on
foo.bar.ti.com:/vol/vol6/TI_apps
                       1048576    475220    573356  46% /home/TI_apps
# ls -1
file.a
file.b
file.c
# cd /home/%T%I_apps
# pwd
/home/%T%I_apps
# df -k .
Filesystem           1k-blocks      Used Available Use% Mounted on
foo.bar.ti.com:/vol/vol6/TI_apps
                       1048576    475220    573356  46% /home/%T%I_apps
# ls -1
file.a
file.b
file.c
# cd /home/ti_apps
# df -k .
Filesystem           1k-blocks      Used Available Use% Mounted on
foo.bar.ti.com:/vol/vol6/TI_apps
                       1048576    475220    573356  46% /home/ti_apps
# ls -1
file.a
file.b
file.c
# cd /home
# ls -1
ti_apps
%T%I_apps
TI_apps
---------------------------------------------------------------------

and on a Solaris 8 client you'll get:
---------------------------------------------------------------------
# cd /home/TI_apps
# pwd
/home/TI_apps
# df -k .
Filesystem            kbytes    used   avail capacity  Mounted on
foo.bar.ti.com:/vol/vol6/TI_apps
                     1048576  475220  573356    46%    /home/TI_apps
# ls -1
file.a
file.b
file.c
# cd /home/%T%I_apps
/home/%T%I_apps: No such file or directory
# cd /home/ti_apps
# df -k .
Filesystem            kbytes    used   avail capacity  Mounted on
foo.bar.ti.com:/vol/vol6/TI_apps
                     1048576  475220  573356    46%    /home/ti_apps
# ls -1
file.a
file.b
file.c
# cd /home
# ls -1
/home/TI_apps
/home/ti_apps
---------------------------------------------------------------------

but on a RHEL 3.0 WS client you'll get the following:
---------------------------------------------------------------------
# cd /home/TI_apps
/home/TI_apps: No such file or directory
# cd /home/%T%I_apps
# pwd
/home/%T%I_apps
# df -k .
Filesystem           1K-blocks      Used Available Use% Mounted on
foo.bar.ti.com:/vol/vol6/TI_apps
                             0         0         0   -  /home/%T%I_apps
# ls -1
# cd /home/ti_apps
/home/ti_apps: No such file or directory
# cd /home
# ls -1
%T%I_apps
---------------------------------------------------------------------

    Since the actual directory is called TI_apps, ideally we'd like to
mount it without the convoluted aliases. Also, note the lack of
information on the contents of the directory when it supposedly mounted.



Version-Release number of selected component (if applicable):
autofs-4.1.3-12

How reproducible:
Always

Steps to Reproduce:
1. Create a Solaris 8 LDAP server
2. Export a NFS mountable directory with a name that includes a
upper-case letter, like "Test_Dir"
3. Make an LDAP entry for automounting /home/Test_Dir
4. Create a RHEL 3.0 (Update 3) WS LDAP client
5. Attempt to automount /home/Test_Dir, example: "cd /home/Test_Dir"
6. If step #5 was successful, check the mount with "df -k" command,
example: "df -k /home/Test_Dir"
7. Also if step #5 was successful, list the contents of the directory,
example: "ls -1 /home/Test_Dir"

Actual Results:  1. Not able to automount the directory without using
"%" to escape the upper-case characters. Had to use "%Test_%Dir"
instead of "Test_Dir".
2. The results from the "df -k" status check are not valid for the
actual mount.
3. If the mount was really made, then we should be able to list the
contents of the directory.

Expected Results:  # cd /home/Test_Dir
# df -k .
Filesystem           1K-blocks      Used Available Use% Mounted on
foo.bar.ti.com:/vol/vol6/Test_Dir
                           100        55        45  55% /home/Test_Dir

Additional info:
Comment 1 Chris Feist 2004-12-21 15:06:53 EST
This was caused by the autofs ldap search only finding the first cn
entry.  This has been fixed in autofs-4.1.3-64.

Note You need to log in before you can comment on or make changes to this bug.