Bug 139553 - after installing fc3 on 2nd drive computer hands at nash when booting to fc2
after installing fc3 on 2nd drive computer hands at nash when booting to fc2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 12:16 EST by ron banks
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 09:05:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ron banks 2004-11-16 12:16:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I was nervous about upgrading from FC2 to FC3 so I installed FC3 on a
2nd SATA drive. I let GRUB install and added the FC2 OS to GRUB during
the install process. I can now boot to FC3 fine but FC2 errored and
when I looked at the GRUB commands they had been written as if it
where Windows with

rootnoverify (hd0,0)
chainloader +1

I deleted those commands and added the original GRUB command from the
grub.conf file on the FC2 installation.

root (hd0,0)
kernel /boot/vmlinuz-2.6.8-1.521 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.8-1.521.img

This starts to load but after displaying:

Red Hat nash version 3.5.22 starting

I get a mount error:

mount: error 6 mounting ext3
pivot: pivot_root(/sysroot,/sysroot/initrd) faliled: 2
umount /initrd/proc failed: 2
kernel panic: No init found. Try passing init=option to kernel.

I have searched around to find similar problems and errors that have
to do with kernel support for ext3 but I don't see how it could be
related since my FC2 installation worked fine before.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
1.Have perfectly fine FC2 installation on 1 drive.
2.Install FC3 on second drive and can boot to it with GRUB.
3.Select FC2 OS from GRUB and get errors listed above.
    

Actual Results:  got errors

Expected Results:  boot to FC2 OS on first drive

Additional info:

I'm assuming it to be a kernel issue. The same GRUB commands worked
previously with the FC2 OS without error.
Comment 1 ron banks 2004-11-16 22:25:37 EST
After I was reassigned to the Grub component I started checking and
found the device.map files different. I don't know if this has any
bearing but it seems as though the number and names of devices have
changed. Does this help.

# this device map was generated by anaconda *my note* on 1rst hard
drive by FC2
(fd0)     /dev/fd0
(hd0)     /dev/hde

# this device map was generated by anaconda *my note* on 2nd hard
drive by FC3
(fd0)     /dev/fd0
(hd0)     /dev/sda
(hd1)     /dev/sdb
Comment 2 ron banks 2004-11-17 13:21:50 EST
 This is the fstab and mtab files on the 2nd drive /dev/sdb w\FC3

fstab:
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/            /                   ext3    defaults        1 1
none               /dev/pts            devpts  gid=5,mode=620  0 0
none               /dev/shm            tmpfs   defaults        0 0
none               /proc               proc    defaults        0 0
none               /sys                sysfs   defaults        0 0
/dev/sda2          swap                swap    defaults        0 0
/dev/hda           /media/cdrecorder   auto   
pamconsole,fscontext=system_u:object_r:removable_t,ro,exec,noauto,managed
0 0
/dev/fd0           /media/floppy       auto   
pamconsole,fscontext=system_u:object_r:removable_t,exec,noauto,managed 0 0

mtab:
/dev/sdb1 / ext3 rw 0 0
none /proc proc rw 0 0
none /sys sysfs rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
usbfs /proc/bus/usb usbfs rw 0 0
none /dev/shm tmpfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
Comment 3 ron banks 2004-11-23 14:16:57 EST
The mount error turned out to be a typo, however, Grub is still broke.
The system gets to

Red Hat nash version 3.5.22 starting

and hangs.

Note You need to log in before you can comment on or make changes to this bug.