This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 139554 - LTC12538-MEMORY test of rhr2 failed on REHL4 Beta2
LTC12538-MEMORY test of rhr2 failed on REHL4 Beta2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: rhr2 (Show other bugs)
2
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Landry
Rob Landry
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 12:19 EST by IBM Bug Proxy
Modified: 2007-04-18 13:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-10 16:55:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2004-11-16 12:19:20 EST
The following has be reported by IBM LTC:  
MEMORY test of rhr2 failed on REHL4 Beta2


Hardware Environment:
 Hostname: plinuxt19b.cn.ibm.com
 HMC     : plinuxt1.cn.ibm.com
 Model   : p655 lpar
 ethernet: pcnet32

Firmware Environment:
 RMRG041029
Software Environment:
 RHEL4 Beta2 isos.
 kernel : 2.6.9-1.648_EL
 rhr2 packages: rhr2-rhel4-0.9-14.9b.noarch.rpm


Steps to Reproduce:
1. Install rhr2-rhel4-0.9-14.9b.noarch.rpm
2. setup rhr2 test env
3. do MEMORY sub-test by redhat-ready.

Actual Results:
Test failed. This caused by uncorrectly set variable $free in MEMORY
script.
Expected Results:
Test pass.

Additional Information:

Modify following lines in file /usr/share/rhr/test/MEMORY.
 20 # local free=`df $SCRATCH | tail -n1 | awk ' { print $4; }'`
To
 21  local free=`df $SCRATCH | tail -n1 | awk ' { print $3; }'`

In RHEL4 Beta2, root partition was created as a LVM, please see following.
[root@plinuxt19b rhr]# df /tmp/rhr 
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      15320532   7220072   7322220  50% /
Note that disk space usage report of /tmp/rhr was spewed two lines.
But in MEMORY script,  variable $free get from the lastest line of df
output. so we have to modify the test script to get correct available
value.
Comment 1 David Lawrence 2004-11-22 12:39:09 EST
Changing product and version
Comment 2 Rob Landry 2004-12-06 16:27:20 EST
should be fixed in rhr2-0.9-14.9f (eg. fixed in CVS)
Comment 3 IBM Bug Proxy 2004-12-20 04:24:39 EST
----- Additional Comments From bujunhui@cn.ibm.com  2004-12-20 04:18 EDT -------
This bug fixed in rhr2-rhel4-0.9-14.9i. 
Comment 4 IBM Bug Proxy 2005-01-11 22:06:52 EST
----- Additional Comments From zhouwu@cn.ibm.com  2005-01-11 22:04 EST -------
close it 

Note You need to log in before you can comment on or make changes to this bug.