Bug 139555 - unable to run service-conf (python related)
unable to run service-conf (python related)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 12:22 EST by Jens Skripczynski
Modified: 2013-04-02 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 17:00:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Skripczynski 2004-11-16 12:22:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
I'm unable to run the command /usr/sbin/service-conf

Version-Release number of selected component (if applicable):
system-config-services-0.8.15-1

How reproducible:
Always

Steps to Reproduce:
1.run `/usr/sbin/service-conf`
2.
3.
    

Actual Results:  /usr/sbin/serviceconf 
Traceback (most recent call last):
  File "/usr/sbin/serviceconf", line 27, in ?
    import gtk
  File
"/usr/src/build/463937-i386/install/usr/lib/python2.3/site-packages/gtk-2.0/gtk/__init__.py",
line 37, in ?
ImportError: /usr/lib/libgtk-x11-2.0.so.0: undefined symbol:
gdk_etent_get_state


Expected Results:  running gui

Additional info:

I did a clean FC3 DVD bit torrent install (with passed md5)
Comment 1 Jens Skripczynski 2004-11-16 12:33:19 EST
I did a update with apt-get (from apt.freshrpms.net) with
apt-get update && apt-get dist-upgrade
So may one upgrade package broke my system :(
Comment 2 Nils Philippsen 2004-11-17 04:06:32 EST
Looks like a problem in pygtk2 and/or gtk2. Which versions do you have?
Comment 3 Jens Skripczynski 2004-11-17 11:00:09 EST
rpm -qa | grep gtk2 
--------
pygtk2-2.4.0-1
gtk2-2.4.13-9
gtk2-devel-2.4.13-9
--------
gtk2-engines-2.2.0-6
pygtk2-libglade-2.4.0-1
Comment 4 Nils Philippsen 2004-11-18 03:49:38 EST
I'm a bit suspicious about that one:

...
ImportError: /usr/lib/libgtk-x11-2.0.so.0: undefined symbol:
gdk_etent_get_state
...

When I check libgtk-x11-2.0.so.0 and libgdk-x11-2.0.so for symbols
containing "state", I don't get that one, but:

nils@gibraltar:~> nm -D /usr/lib/libgtk-x11-2.0.so|grep state
         U gdk_event_get_state
...
nils@gibraltar:~> nm -D /usr/lib/libgdk-x11-2.0.so|grep state
...
0054833a T gdk_event_get_state
...

A question: do any other gtk2 programs work on your machine? Please
verify that the installed gtk2 packages aren't broken:

rpm -V gtk2 gtk2-devel
Comment 5 Jens Skripczynski 2004-11-18 17:00:57 EST
thx !!
rpm -V gtk2 gtk2-devel
showed one md5 mismatch.

I solved my problem by removing locally cached rpm's in /var/cache/apt
and reinstalled the gtk2 rpm with
apt-get --reinstall install gtk2 gtk2-devel

Thank you for your help.

Note You need to log in before you can comment on or make changes to this bug.