This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 139582 - NFS client doesn't push aio requests aggressively
NFS client doesn't push aio requests aggressively
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 15:07 EST by Chuck Lever
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:14:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
NFS client now pushes queued aio requests immediately (1.75 KB, patch)
2004-11-16 15:08 EST, Chuck Lever
no flags Details | Diff

  None (edit)
Description Chuck Lever 2004-11-16 15:07:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When using aio with NFS files, performance is terrible, or the
application never completes.  The problem is because the NFS client
doesn't push out reads or writes after they are queued by aio.

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.EL

How reproducible:
Always

Steps to Reproduce:
1. See 137830 and use OraSim
2.
3.
    

Actual Results:  OraSim reports "FATAL: Async I/O queue still jammed
after 10000 milliseconds" or other errors that suggests I/O is not
progressing.

Expected Results:  OraSim should run with performance as good as or
better than with normal I/O, without error.

Additional info:

nfs_kvec_read and nfs_kvec_write should flush queued read and write
requests after generic_file_kvec_* returns.
Comment 1 Chuck Lever 2004-11-16 15:08:57 EST
Created attachment 106843 [details]
NFS client now pushes queued aio requests immediately

For your review and comment
Comment 2 RHEL Product and Program Management 2007-10-19 15:14:02 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.