Bug 139614 - fdisk don't show same things between fc1 & fc3
fdisk don't show same things between fc1 & fc3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 17:13 EST by Philippe SARCHER
Modified: 2015-01-04 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-12 16:19:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe SARCHER 2004-11-16 17:13:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
I'm using Fedora core 1 and I want to install Fedora core 3

With fc1 fdisk /dev/hdc show

Disk /dev/hdc: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes

P�riph�rique Amorce    D�but       Fin    Blocs   Id  Syst�me
/dev/hdc1   *         1        65    522081   83  Linux
/dev/hdc2            66       702   5116702+  83  Linux
/dev/hdc3           703       767    522112+  82  Echange Linux
/dev/hdc4           768      4865  32917185    5  Etendue
/dev/hdc5           768      1376   4891761   83  Linux
/dev/hdc6          1377      4865  28025361   83  Linux

but with fc3 it shows

Disk /dev/hdc: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdc1   *           1        1216     9767488+  55  EZ-Drive
/dev/hdc2            1217        4864    29302560   55  EZ-Drive

and I can't install fc3 on it without all break

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot with fc3 "linux rescue"
2.fdisk -l /dev/hdc
3.
    

Actual Results:  see above

Expected Results:  the same thing than with fc1 (see above)

Additional info:
Comment 1 Elliot Lee 2004-11-19 15:13:30 EST
What are the contents of /proc/partitions under FC1 and FC3?
Comment 2 Philippe SARCHER 2004-11-19 17:58:25 EST
under FC1 :
major minor  #blocks  name     rio rmerge rsect ruse wio wmerge wsect
wuse running use aveq

  22     0   39082680 hdc 32203 77890 869688 271020 28776 65083 758264
111890 -67 22124860 21609143
  22     1     522081 hdc1 11 45 112 80 0 0 0 0 0 80 80
  22     2    5116702 hdc2 22 103 274 180 4 3 32 10 0 190 190
  22     3     522112 hdc3 1929 9613 92192 23950 3436 31010 279392
61890 0 17690 85920
  22     4          1 hdc4 6 0 12 50 0 0 0 0 0 50 50
  22     5    4891761 hdc5 30009 66719 773826 244560 25336 34070
478840 49990 0 164140 294560
  22     6   28025361 hdc6 14 54 136 100 0 0 0 0 0 100 100
   3     0   78150744 hda 1089 21791 23845 3810 13 4 98 10 -39
22128500 8019910
   3     1   16064968 hda1 29 54 147 90 0 0 0 0 0 90 90
   3     2          1 hda2 0 0 0 0 0 0 0 0 0 0 0
   3     5   20482843 hda5 939 21099 22102 3180 2 0 2 0 0 1780 3180
   3     6   20482843 hda6 13 33 122 80 3 0 24 0 0 80 80
   3     7   21117411 hda7 20 89 266 110 8 4 72 10 0 120 120
   3    64     651888 hdb 64258 409521 1897136 611300 0 0 0 0 61
22116370 30741920

under FC3 :
major minor  #blocks  name

   3     0   78150744 hda
   3     1   16064968 hda1
   3     2          1 hda2
   3     5   20482843 hda5
   3     6   20482843 hda6
   3     7   21117411 hda7
  22     0   39082680 hdc
  22     1    9767488 hdc1
  22     2   29302560 hdc2
   7     0      72820 loop0

Notice : under FC3, I boot with the first cd & linux rescue (fc3 not
installed)
Comment 3 Ed Kidwell 2004-11-26 12:03:50 EST
I'm having the exact same problem with my /dev/hdc drive (250G 
Maxtor). I can boot to FC1 rescue disk, and everything is fine. But 
when I boot to FC3, the drive is not recognized.

I have passed the following into the kernel without success:
hdc=30515,255,63    <- I got these numbers from FC1 fdisk
hdc=16443,255,16    <- I got these numbers from BIOS LBA params
hdc=ide-scsi        <- Tried in desperation [grin]

=================================================
ONE POSSIBILITY THAT HAS CROSSED MY MIND IS THAT FC3 IS NOT 
RECOGNIZING MY DRIVE BECAUSE IT IS ON THE SAME IDE CABLE AS MY CDROM 
DRIVE. Here's my config:
hda = 60G IBM drive
hdb = 160G Western Digital drive
hdc = 250G Maxtor (THIS ONE NOT RECOGNIZED)
hdd = 52x24x52 MSI CDRW drive
=================================================

=================================================
FC1 (fdisk 'p' output):
=================================================
Device     Boot  Start     End   # cyls      Blocks  Id    System
/dev/hdc1    *       0+  15306    15307-  122953446  83    Linux
/dev/hdc2        15307   30514    15208   122158260  83    Linux

=================================================
Here's the FC3 output (copied directly from terminal):
=================================================
[root@info ~]# sfdisk -d /dev/hdc
detected Disk Manager - unable to handle that
 /dev/hdc: unrecognized partition
No partitions found
=================================================
[root@info ~]# fdisk /dev/hdc

The number of cylinders for this disk is set to 30515.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): p

Disk /dev/hdc: 251.0 GB, 251000193024 bytes
255 heads, 63 sectors/track, 30515 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdc1   *           1        1023     8217243   55  EZ-Drive


Comment 4 Philippe SARCHER 2004-11-30 12:23:42 EST
With a knoopix CD (knoopix 3.4 loading with knoppix26) I have the same
problem. 

For information, my boot CDROM (a DVD reader) is on hdb

I think it is a kernel problem 

Comment 5 Elliot Lee 2004-12-01 18:29:12 EST
The difference in the /proc/partitions output under FC1 vs FC3 points
to a kernel problem recognizing all the partitions on /dev/hdc
Comment 6 Philippe SARCHER 2004-12-10 10:22:53 EST
I have found one thing that seems to be important :

When I boot whith my fc1, the dmesg reports (I grep it with "hd")

Kernel command line: ro root=LABEL=/1 hdd=ide-scsi vga=773
ide_setup: hdd=ide-scsi
    ide0: BM-DMA at 0xfc00-0xfc07, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xfc08-0xfc0f, BIOS settings: hdc:DMA, hdd:DMA
hda: WDC WD800BB-00CAA1, ATA DISK drive
hdb: Pioneer DVD-ROM ATAPIModel DVD-117 0107, ATAPI CD/DVD-ROM drive
hdc: WDC WD400BB-00CXA0, ATA DISK drive
hdd: ATAPI DVD RW 8XMax, ATAPI CD/DVD-ROM drive
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 156301488 sectors (80026 MB) w/2048KiB Cache, CHS=9729/255/63,
UDMA(100)
hdc: attached ide-disk driver.
hdc: host protected area => 1
hdc: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=77545/16/63,
UDMA(100)
 hda: hda1 hda2 < hda5 hda6 hda7 >
 hdc: [EZD] [remap 0->1] [4865/255/63] hdc1 hdc2 hdc3 hdc4 < hdc5 hdc6 >
hdb: attached ide-cdrom driver.
hdb: ATAPI 40X DVD-ROM drive, 256kB Cache, UDMA(66)
hdd: attached ide-scsi driver.

I remember that the disk come from an old computer which didn't
support  disk larger than 4Gb and I needed to install EZD on it !

Perhaps 2.6 kernel don't support this thing ???

If it don't, how can I remove the EZD MBR whitout breaking my partitions ?

Comment 7 Philippe SARCHER 2004-12-12 16:17:45 EST
I found the solution :

If I want to use my disk "as is" I must put the paramter "hdc=remap"
on boot


Note You need to log in before you can comment on or make changes to this bug.