Bug 139634 - SystemError: (6, 'No such device or address')
SystemError: (6, 'No such device or address')
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 20:27 EST by Chris
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 15:01:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (726.42 KB, text/plain)
2004-11-17 23:11 EST, Chris
no flags Details

  None (edit)
Description Chris 2004-11-16 20:27:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040913

Description of problem:
Traceback (most recent call last):
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py",
line 1074,
 in handleRenderCallback
    self.currentWindow.renderCallback()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/iw/progress_gui.py"
, line 242, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py",
line 789,
in nextClicked
    self.dispatch.gotoNext()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py", line
171, in gotoNext
    self.moveStep()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py", line
239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/packages.py", line
689, in doPreInstall
    method.mergeFullHeaders(id.grpset.hdrlist)
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/harddrive.py", line
 172, in mergeFullHeaders
    self.mountMedia(1)
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/harddrive.py", line
 52, in mountMedia
    self.mountDirectory()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/harddrive.py", line
 90, in mountDirectory
    readOnly = 1);
  File "/usr/lib/anaconda/isys.py", line 188, in mount
    rc = _isys.mount(fstype, device, location, readOnly, bindMount,
remount)
SystemError: (6, 'No such device or address')

Local variables in innermost frame:
bindMount: 0
devName: /tmp/sda3
remount: 0
fstype: ext2
readOnly: 1
location: /tmp/isodir
device: /tmp/sda3
createdNode: 1

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Attempt to install Fedora Core 3 using HD install method
2.
3.
    

Actual Results:  Install failed and forced to reboot.

Expected Results:  Should have installed Fedora Core 3

Additional info:
Comment 1 Jeremy Katz 2004-11-16 20:41:55 EST
Can you attach the complete dump file you received?
Comment 2 Chris 2004-11-17 23:11:55 EST
Created attachment 106930 [details]
anacdump.txt
Comment 3 Chris 2004-11-21 11:30:49 EST
Added attachment anacdump.txt
Comment 4 Jeremy Katz 2005-02-01 22:12:07 EST
Is this reproducible?  Can you try booting with 'linux ide=nodma' and see if
that helps?
Comment 5 Jeremy Katz 2005-09-21 15:01:30 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further information, feel free to
add to the report and reopen.

Note You need to log in before you can comment on or make changes to this bug.