Bug 139643 - lsusb hangs when memory stick is installed along with psc printer
lsusb hangs when memory stick is installed along with psc printer
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 00:28 EST by Jerry
Modified: 2015-01-04 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 18:57:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry 2004-11-17 00:28:18 EST
Description of problem:

lsusb hangs when invoked with memory stick inserted.  A partial
listing is provided then it hangs.  If the stick is pulled, the
listing resumes and completes.  lsusb also hangs and never returns
control to the console prompt when printer is unplugged from the usb
port.  Printer is a HP psc2175 printer scanner.

Version-Release number of selected component (if applicable):

usbutils-0.11-6.1

How reproducible:

Every time.  

Steps to Reproduce:
1.Boot to stable condition
2.Enter lsusb command
3.Observe normal listing which includes mouse and printer installed
4.Plug in memory stick.
5.Enter lsusb command.
6.Observe partial lsiting and command does not complete.
7.Remove memory stick and command completes, memory stick not listed.
  
Actual results:

[root@quantum bench]# /sbin/lsusb
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 002: ID 045e:0039 Microsoft Corp. IntelliMouse Optical
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 03f0:2b11 Hewlett-Packard
Bus 002 Device 001: ID 0000:0000

Expected results:

[root@quantum bench]# /sbin/lsusb
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 002: ID 045e:0039 Microsoft Corp. IntelliMouse Optical
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 03f0:2b11 Hewlett-Packard
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

Additional info:

None
Comment 1 Jerry 2004-11-17 00:29:13 EST
Occasionally it hangs and I can't get a back to console. lsusb then is
a zombie.
Comment 2 Jerry 2004-12-03 20:05:37 EST
In searching google I have found refrence to a problem with some usb
memory devices reporting an incorrect number of sectors.  There was a
suggested patch to the 2.6.9 kernel to work around these problems.

http://marc.theaimsgroup.com/?l=linux-scsi&m=109890563230889&w=2

I do not know if this is related or not.  I have not tried to do the
patch at this point.  I have been experimenting the memory stick and I
have managed to hang the system without the printer installed.  I
tried to reboot and got a kernel back trace.  This tells me we have a
more serious bug here, because the kernel is obviously not supposed to
crash.  I will tryto dig out some log info.
Comment 3 Jerry 2004-12-03 20:34:00 EST
After a clean boot using kernel-2.6.9-1.681_FC3smp when I insert the
usb memory into the usb port, the device shows up automatically in the
system and I can readily mount the device.

I can then unmount and remove the device.  After doing this the first
time, I can no longer repeat the process and the device no longer
shows up.  I am using a SanDisk Cruzer mini 256 mb.
Comment 4 Clyde E. Kunkel 2004-12-04 22:33:43 EST
I have a similar situation with the same kernel.  Plugging in a PNY
multi-device reader with a 16 MB CF card inserted, I can see it
immediately.  Howerever, after unplugging and replugging, I cannot see
the device, it no longer shows up in /media and /sbin/lsusb hangs
without any output.  Unplugging does not change /sbin/lsusb behavior.
 In addition, rebooting with the PNY plugged fails after "checking
'hlt' instruction...OK"

Unplugging the device allows a normal boot.

Also, a 128MB SmartMedia card plugged into the device never shows
under any circumstances.  The PNY is working ok--tested on a WinXP
machine.
Comment 5 Thomas Woerner 2004-12-06 05:33:32 EST
This seems to be a driver problem. Assigning to kernel.
Comment 6 Jerry 2005-02-01 01:22:07 EST
Now resolved on my system
Comment 7 Dave Jones 2005-07-15 14:39:58 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 8 Jerry 2005-07-15 17:08:55 EDT
Fixed.

Note You need to log in before you can comment on or make changes to this bug.