Bug 139659 - can't set monitor mode
Summary: can't set monitor mode
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-17 09:38 UTC by Yan Nan
Modified: 2015-01-04 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-24 03:16:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yan Nan 2004-11-17 09:38:38 UTC
Description of problem:
ipw2100/ipw2200 can't set monitor mode on rhel beta2.

Version-Release number of selected component (if applicable):
ipw2100:0.56
ipw2200:0.12

How reproducible:
every time.

Steps to Reproduce:
1. % modprobe ipw2200
2. % iwconfig eth1 mode monitor
it gives error:
Error for wireless request "Set Mode" (8B06):
   SET failed on dvice eth1; Invalid argument.
  
Actual results:
it gives error:
Error for wireless request "Set Mode" (8B06):
   SET failed on dvice eth1; Invalid argument.

Expected results:
the mode is changed to monitor

Additional info:
we use the driver which included by the OS itself.

Comment 1 Dave Jones 2004-11-27 06:03:59 UTC
should be fixed in cvs. (enabled PROMISC config option for this chipset).


Comment 2 Yan Nan 2004-12-24 03:16:14 UTC
Did this test again on RHEL40-Pre-RC2,Now the 1.0.0 2100 driver can 
set monitor mode successfully; 0.13 2200 driver can't set monitor 
mode due to the driver itself,not a integration bug.


Note You need to log in before you can comment on or make changes to this bug.