Bug 1396675 - vdsm-tool configure --module sanlock doesn't actually confirm proper group membership
Summary: vdsm-tool configure --module sanlock doesn't actually confirm proper group me...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Suchanek
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-18 23:16 UTC by Dax Kelson
Modified: 2017-01-13 15:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1413079 (view as bug list)
Environment:
Last Closed: 2017-01-13 15:08:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dax Kelson 2016-11-18 23:16:33 UTC
Description of problem:

TL;DR:

The "vdsm-tool configure --module sanlock" command should NOT report success if it isn't able to add the sanlock users to the groups and instead should report a helpful error message.

LONG VERSION:

vdsm-tool configure --module sanlock

The above command is supposed to add the sanlock user to the qemu and kvm groups.

If kvm is coming from IDM, this command will NOT be able to add the sanlock user to the group, however, the command will still report success! 

I know it is not advisable to have system group in IDM, but for other complicated reasons it was.

The "vdsm-tool configure" command should NOT report success if it isn't able to add the sanlock users to the groups and instead should report a helpful error message.

Comment 2 Jaroslav Suchanek 2017-01-13 15:08:03 UTC
Well I believe this is for RHV product. As I did not find any better way how to move it there I just cloned it as bug 1413079. Closing this one.


Note You need to log in before you can comment on or make changes to this bug.