Bug 139684 - (IT#54202) with NTML authentication, user names that are authenticated are not logged
with NTML authentication, user names that are authenticated are not logged
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: squid (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
:
Depends On:
Blocks: 132991
  Show dependency treegraph
 
Reported: 2004-11-17 10:00 EST by Steve Conklin
Modified: 2014-08-31 19:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 17:07:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Conklin 2004-11-17 10:00:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
From IT#54202:

When we use squid-2.5.STABLE3-3.3E with NTML authentication, user names
that are authenticated are logged. But when we use
squid-2.5.STABLE3-6.3E.2, the user names are not logged:

- Log from squid-2.5.STABLE3-3.3E
10.1.0.123 - testdomain\testuser [04/Nov/2004:08:13:08 +0900] "GET
http:// ...

- Log from squid-2.5.STABLE3-6.3E.2
10.1.0.123 - testdomain [04/Nov/2004:09:32:33 +0900] "GET http:// ...


This seems to be the same problem as described at the URL below. Is this
a bug? http://www.squid-cache.org/bugs/show_bug.cgi?id=998


Version-Release number of selected component (if applicable):
squid-2.5.STABLE3-6.3E.2

How reproducible:
Always

Steps to Reproduce:
1. Use squid with NTML
2.
3.
    

Actual Results:  User names are not logged

Expected Results:  User Names should be logged

Additional info:

A trivial patch which fixes this is found here:

http://www.squid-cache.org/bugs/show_bug.cgi?id=998
Comment 3 Tim Powers 2005-05-19 17:07:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-442.html

Note You need to log in before you can comment on or make changes to this bug.