Bug 139687 (IT#53147) - Satellite Server does not show valid dependencies for packages.
Summary: Satellite Server does not show valid dependencies for packages.
Status: CLOSED CURRENTRELEASE
Alias: IT#53147
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: unspecified
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Shannon Hughes
QA Contact: Max Spevack
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 145821
TreeView+ depends on / blocked
 
Reported: 2004-11-17 15:24 UTC by Steve Conklin
Modified: 2007-07-31 19:11 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-04-08 16:33:13 UTC


Attachments (Terms of Use)

Description Steve Conklin 2004-11-17 15:24:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
From IT#53147:

 Following these links on the Satellite Server, to look at a
particular package:
Channels -->  <Select a Channel> -->  Packages  -->  <Select a
Package>  "laus-libs-0.1-65RHEL3"  -->  Dependencies  
The results are:
************************************************************
Requires:
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.3)
liblaus.so.1
rpmlib(CompressedFileNames)-3.0.4-1
rpmlib(PayloadFilesHavePrefix)-4.0-1
rpmlib(VersionedDependencies)-3.0.3-1

Provides:
laus-libs-0.1-65RHEL3
liblaus.so.1
liblaussrv.so.0
pam_laus.so

Obsoletes:
laus-0.1-65RHEL3
************************************************************

When I look at the actual dependencies on the package using the rpm
command, I see the following:

==============================================
Package Provides:
==============================================
liblaus.so.1
liblaussrv.so.0
pam_laus.so
laus-libs = 0.1-65RHEL3
==============================================
Package Requires:
==============================================
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.3)
liblaus.so.1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
==============================================
Package Obsoletes:
==============================================
laus < 0.1-65RHEL3
==============================================

The results on the Satellite Server does not correctly display the
version information about the dependencies.  Specifically, the SatServ
shows that this package obsoletes a package that it requires, instead
of it actually obsoleting all older versions of that package.

It appears that the Sat Serv is not showing the "REQUIREFLAGS",
"PROVIDEFLAGS", or "OBSOLETEFLAGS" tag values from the rpm package.

Version-Release number of selected component (if applicable):
3.2

How reproducible:
Always

Steps to Reproduce:
1. Follow steps in description
2.
3.
    

Actual Results:  dependencies are not correctly displayed.

Expected Results:  dependencies should be correctly displayed.

Additional info:

Comment 1 Todd Warner 2004-11-17 22:27:12 UTC
Duplicated in RHN Sat 3.4 as well.

Comment 2 Mihai Ibanescu 2004-11-19 13:58:18 UTC
This is an artifact of how the web site displays dependencies. They
are actually correct in the database.

Comment 3 Todd Warner 2004-12-01 07:27:44 UTC
Assigning to bretm then.
Customer Facing Yes --> No. 

Comment 4 Bret McMillan 2004-12-02 19:46:28 UTC
moving to 370

Comment 6 Shannon Hughes 2005-02-01 14:35:47 UTC
added estimates

Comment 7 Kevin Krafthefer 2005-02-01 17:44:05 UTC
Shannon, could you please convey these estimates to me?

Comment 9 Shannon Hughes 2005-02-21 22:07:54 UTC
TEST PLAN, follow the original private comment from Steve. 

Also, you may want to test a few other packages. 

Comment 10 Max Spevack 2005-03-03 06:23:42 UTC
Ran through the tests using laus-libs-0.1-66RHEL3 and verified that
the requires/provides/obsoletes output from rpm matches the
information within the RHN site.

Comment 11 Todd Warner 2005-04-08 16:33:13 UTC
mass move: PROD_READY --> CLOSED:CURRENTRELEASE


Note You need to log in before you can comment on or make changes to this bug.