Bug 139696 - GFS panic: assertion: "ip->i_num.no_formal_ino == ip->i_di.di_num.no_formal_ino"
Summary: GFS panic: assertion: "ip->i_num.no_formal_ino == ip->i_di.di_num.no_formal_ino"
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs   
(Show other bugs)
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: michael conrad tadpol tilstra
QA Contact: GFS Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-17 16:29 UTC by Corey Marthaler
Modified: 2010-01-12 03:01 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-18 20:27:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Corey Marthaler 2004-11-17 16:29:25 UTC
Description of problem:
I had I/O going on 5 nodes (morph-01 - morph-05), morph-01 appeared to
have died due to bz129007. This caused morph-04 to hit this panic a
min later which may be related to bz128567:

GFS: fsid=morph-cluster:gfs0.3: jid=1: Done
Info fld=0x0, Current sda: sense key No Sense
  mh_magic = 0x01161970
  mh_type = 4
  mh_generation = 12
  mh_format = 400
  mh_incarn = 2
  no_formal_ino = 82515456
  no_addr = 82515456
  di_mode = 0666
  di_uid = 0
  di_gid = 0
  di_nlink = 0
  di_size = 1024
  di_blocks = 1
  di_atime = 1100699042
  di_mtime = 1100699043
  di_ctime = 1100699217
  di_major = 0
  di_minor = 0
  di_rgrp = 82515424
  di_goal_rgrp = 82515424
  di_goal_dblk = 27
  di_goal_mblk = 27
  di_flags = 0x00000000
  di_payload_format = 0
  di_type = 1
  di_height = 0
  di_incarn = 0
  di_pad = 0
  di_depth = 0
  di_entries = 0
  no_formal_ino = 0
  no_addr = 0
  di_eattr = 0
  di_reserved =
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00
Kernel panic - not syncing: GFS: Assertion failed on line 247 of file
/usr/src/cluster/gfs-kernel/src/gfs/inode.c
GFS: assertion: "ip->i_num.no_formal_ino == ip->i_di.di_num.no_formal_ino"
GFS: time = 1100699475
GFS: fsid=morph-cluster:gfs1.3: inode = 35835474/35835474



Version-Release number of selected component (if applicable):
GFS <CVS> (built Nov 16 2004 10:50:07) installed

How reproducible:
Didn't try

Comment 1 Kiersten (Kerri) Anderson 2005-07-18 20:13:44 UTC
Any reproduction since this time?

Comment 2 Corey Marthaler 2005-07-18 20:27:38 UTC
Have not seen in a very long time, will reopen if this shows up again.


Note You need to log in before you can comment on or make changes to this bug.