Bug 139698 - current->personality is not being set to PER_LINUX32
Summary: current->personality is not being set to PER_LINUX32
Status: CLOSED DUPLICATE of bug 139701
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ia32el   
(Show other bugs)
Version: 4.0
Hardware: ia64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-17 16:39 UTC by Joe Maionchi
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-17 19:12:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Maionchi 2004-11-17 16:39:15 UTC
Description of problem:

The new version of ia32-el does not set "current->personality" to 
PER_LINUX32.  Our 64-bit kernel modules rely on this to determine 
whether the calling process is 32-bit or 64-bit.  This was getting 
set in earlier RHEL4 drops.

Version-Release number of selected component (if applicable):

ia32el-1.1-8.ia64.rpm

How reproducible:

Very.

Steps to Reproduce:
1. build a 32-bit app that calls an ioctl into a 64-bit kernel module.
2. run the 32-bit app on IA64 using the ia32EL.
3. check inside the kernel that current->personality is not set to 
PER_LINUX32.
  
Actual results:

current->personality is not set.

Expected results:

current->personality = PER_LINUX32 for 32-bit calling processes.

Additional info:

Is this a bug, or an intended change.  If intended, what will be the 
new method for determining whether the calling process is 32-bit or 
64-bit?  Ideally, we'd like this to be the same across all 64-bit 
platforms (ie: on x86_64 we also check current->personality).

Comment 1 Jakub Jelinek 2004-11-17 19:12:22 UTC

*** This bug has been marked as a duplicate of 139701 ***


Note You need to log in before you can comment on or make changes to this bug.