Bug 139704 - rhgb prevents vncserver service from starting
rhgb prevents vncserver service from starting
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 11:59 EST by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 09:48:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-11-17 11:59:13 EST
User-Agent:       
Build Identifier: 

If a vncserver is configured on :1 in /etc/sysconfig/vncservers, RHGB prevents
it from starting because it occupies that display number while the vncserver
initscript runs.

You could do something like the following to figure out the lowest free display
for RHGB to use:

declare -a displays
for n in $VNCSERVERS
do
  displays[${n%:*}]=${n#*:}
done
for n in $(seq 1 99)
do
  if [ -z "${displays[$n]}" ]
  then
    echo $n
    break
  fi
done


Reproducible: Always
Steps to Reproduce:
1. Put VNCSERVERS="1:root" in /etc/sysconfig/vncservers
2. Boot with 'rhgb' on the command line

Actual Results:  
No VNC session on display :1.

Expected Results:  
Root's VNC session on display :1.
Comment 1 Daniel Veillard 2004-11-30 09:48:07 EST
Considered fixed in 0.16.1 pushed as an errata, it now uses display :9 

Daniel

Note You need to log in before you can comment on or make changes to this bug.