Bug 139718 - Merge QA_3_14_0 and resolve open development branches for CC
Merge QA_3_14_0 and resolve open development branches for CC
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 13:31 EST by Mike McCune
Modified: 2007-06-20 16:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-02 17:13:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2004-11-17 13:31:31 EST
Here is the email where we discussed how to resolve some open issues
reguarding some development branches that were used during the 3_14_0
development phase.



> Dave Parker wrote:
>
>> Mike McCune will be doing cvs "merge" operations on the monitoring
codebase tomorrow.
>>
>> Here's the sequence of steps we agreed on:
>>
>> 1) tag HEAD, QA_3_14_0, and triumph
>
>
>
>
>
>
> What tag name should I use?  RHNCC_HOSTED_PRE314REWORK ?


 That's good

>
>
>> 2) create a branch off of HEAD called RHNCC_HOSTED_HEAD
>
>
>
>
>
>
> easy enough.
>
>> 3) Overwrite RHNCC_HOSTED_HEAD with QA_3_14_0 - this should include
the frontend code, which is on the same branch.
>
> Ok.
>
>> 4) Overwrite HEAD with triumph
>
>
> Just to confirm, we have here:
>
>                        triumph branch -->    ---------------------
>                                             /                     \
>                                            /                      *B*
> HEAD                                     *A*
>
------------------------------------------------------------------------*C*
>                     \            /          |
>                      \          /        selective
> QA_3_13_0 branch -->  ----------          merging
>                                 \           |
>                                  \          V
>            DEV_3_14_0 branch -->  ------------
>                                               \
>                                                \
>                          *QA_3_14_0 branch -->  -----------
>
>
> and want to make that triumph branch at the top the HEAD.  So we are
whacking all changes since it was branched at point *A* and making the
tip of the triumph branch (point *B*) the actual HEAD at point *C*.
>

That is correct.

>
>> *) bug_91760 continues to live off of the triumph branch until such
time as kja desires otherwise.
>>
>> We need to coordinate development activities around this, so if
everyone's online at 9:00a PST, we'll congregate in #rhncc and
collectively give Mike the go.
>>
>> We will also need to run some permutation of the postrelease flow
to get Upgrade and TheHat into proper shape on the RHNCC_HOSTED_HEAD
branch, after which we can safely forget about it, perhaps forever.
>
>
>
>
>

Note You need to log in before you can comment on or make changes to this bug.