Bug 139720 - iptables -nL incorrectly lists icmp type ranges
Summary: iptables -nL incorrectly lists icmp type ranges
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iptables   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Thomas Woerner
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-17 18:39 UTC by Brad Smith
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 14:34:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brad Smith 2004-11-17 18:39:51 UTC
If all icmp types are matched by an iptables rule (as is the case in
RHEL4b2's default configuration), then iptables -L correctly shows
"icmp any" in the rightmost column. However, iptables -nL shows "icmp
type 255" instead of "icmp type 0:255".

Comment 1 Thomas Woerner 2004-11-18 14:34:25 UTC
type 255 is any.

Closing as "NOT A BUG".


Note You need to log in before you can comment on or make changes to this bug.