Bug 139736 - Command '%' without job number doesn't work
Command '%' without job number doesn't work
Status: CLOSED DUPLICATE of bug 134138
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 14:41 EST by Samuli Kärkkäinen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samuli Kärkkäinen 2004-11-17 14:41:23 EST
Description of problem:
Starting say "emacs -nw", suspending that with ^Z and then issuing
command "%" in the shell used to resume the emacs process, as that was
the most recently suspended process. Now with FC3 that says

bash: fg: %: no such job

And I must instead do "%1" or whatever the job number is.
Comment 1 Tim Waugh 2004-11-17 16:49:56 EST

*** This bug has been marked as a duplicate of 134138 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.