Bug 139765 - Kernel oops on usb disconnect
Kernel oops on usb disconnect
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 17:00 EST by Brian Daniels
Modified: 2016-03-27 10:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 00:48:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of kernel oops (3.95 KB, text/plain)
2004-11-17 17:00 EST, Brian Daniels
no flags Details
dmesg log (2.08 KB, text/plain)
2004-11-24 05:46 EST, vvs
no flags Details

  None (edit)
Description Brian Daniels 2004-11-17 17:00:02 EST
Description of problem:
Disconnecting external usb 2.0 dvd-burner causes oops.  Log attached.


How reproducible:
always

Steps to Reproduce:
1. Attach external DVD burner
2. mount, read files, umount
3. Unplug from usb port
4. boom.
  
Actual results:
Oops!

Expected results:
Disconnection and removal of mount point, system keeps working.

Additional info:
Motherboard is a MSI Neo2 Platinum plus (Socket 939) with Athlon 64
cpu.  Burner is a Sony DRX-510UL.  Kernel is stock 2.6.9-1.667
Comment 1 Brian Daniels 2004-11-17 17:00:54 EST
Created attachment 106919 [details]
Log of kernel oops
Comment 2 vvs 2004-11-24 05:45:15 EST
I have a similar situation with Plextor PX-708UF (firmware 1.08). When
I blank or write a RW disc and power off the writer after that, I get
a kernel oops.
Comment 3 vvs 2004-11-24 05:46:30 EST
Created attachment 107386 [details]
dmesg log
Comment 4 vvs 2004-11-24 05:47:52 EST
Forgot to mention that this happens with stock kernel and
2.6.9-1.681_FC3 as well.
Comment 5 Sitsofe Wheeler 2004-12-02 14:06:50 EST
This looks like a dup of bug 139665
Comment 6 petrosyan 2005-01-05 00:41:12 EST
this has been fixed in kernel-2.6.9-1.724_FC3

Note You need to log in before you can comment on or make changes to this bug.