Bug 139768 - (IT_39839) cdplayer_applet2 crashes regularly when removing from panel or logging out
cdplayer_applet2 crashes regularly when removing from panel or logging out
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gnome-applets (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
Depends On:
Blocks: 136201
  Show dependency treegraph
 
Reported: 2004-11-17 17:24 EST by Havoc Pennington
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: gnome-applets-2.2.2-2.1E
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 23:25:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2004-11-17 17:24:55 EST
This has been reproduced on multiple systems.

From our testing, it looks like the "cdplayer_applet2" application
only crashes if it is removed from the panel while a disc is paused -
it does not crash if the disc is playing or stopped, only when it is
paused.

To reproduce this problem, I did the following:
   * right-clicked the panel
   * clicked Add To Panel -> Multimedia -> CD Player
   * inserted a music CD in the disc tray
   * clicked the play button and let the disc start playing
   * clicked the pause button
   * right-clicked the panel application
   * clicked Remove From Panel

At that point, the application was removed from the panel and I saw the
following error message pop up:

Application "cdplayer_applet2" (process <pid>) has crashed due to a
fatal error. (Aborted)

In my next update, I'll attach a screenshot of the error.
----------
Action by: schapin-Dreamworks
Issue Registered
----------
Action by: schapin-Dreamworks
Attached is a screenshot of the error message (it\'s a PNG file)

Status set to: Waiting on Tech
File uploaded: cdplayer_crash.rgb

----------
Action by: mkunjal
This is reporducable. Same behavior on RHL 9. However its fixed on
Fedora Core 1...


Escalating it 


Issue escalated to GPS by: mkunjal
.mkunjal assigned to issue for DreamWorks.

Category set to: Applications

----------
Action by: mkunjal



Issue escalated to Support Engineering Group by: mkunjal
.mkunjal assigned to issue for GPS.

----------
Action by: nmurray
There's nothing immediately obvious in the applet code relating to
exit under pause, or changes in/around the pause or exit handling.


However, this is very easy to reproduce. 

Escalating to SE.

nmurray assigned to issue for Support Engineering Group.

----------
Action by: tkramer
This has been escalated upstream (on 5-21) since it was clearly
documented on how to reproduce.


----------
Action by: faith
This was marked with internal status of Waiting on Sustaining, but
wasn't escalated.  Based on Norm's note, I think he intended to
escalate and some error occured.  Hence, I'm escalating now.  Thanks, Rik.


Issue escalated to Sustaining Engineering by: faith.

----------
Action by: lana
Hi SE,

Can we get an update please?


----------
Action by: schapin-Dreamworks
Note that this is still happening with WS3 U3


----------
Action by: lana
Hi SE,

Can someone look at this ticket and advise next steps?

Thanks.


----------
Action by: jneedle


hp assigned to issue for Sustaining Engineering.
Comment 1 Mark McLoughlin 2004-11-18 03:54:06 EST
This looks like it could be it:

  http://bugzilla.gnome.org/show_bug.cgi?id=96200

Trivial patch attached there
Comment 2 Mark McLoughlin 2004-11-18 13:45:48 EST
Fixed in gnome-applets-2.2.2-2.1E.

Errata is RHBA-2004:649, will be in RHEL3 U5
Comment 3 Jay Turner 2005-03-04 00:11:25 EST
Reopening because the errata tool will close these issues when the
errata is released.
Comment 4 Dennis Gregorovic 2005-05-19 23:25:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-444.html

Note You need to log in before you can comment on or make changes to this bug.