Bug 139770 - cman join attempt without ccsd running will appear hung
cman join attempt without ccsd running will appear hung
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: ccs (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
: 139975 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 17:46 EST by Corey Marthaler
Modified: 2009-04-16 16:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:32:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2004-11-17 17:46:44 EST
Description of problem:
If I try to join the cluster and ccsd isn't running, cman will
continue to attempt to connect forever and appears hung. It'd be nice
if it gave up after so many attempts, or errored that the user should
use the -X flag to ignore ccsd, or say "hey buddy, how 'bout starting
ccsd?".

How reproducible:
Always
Comment 1 Christine Caulfield 2004-11-18 03:32:39 EST
Assigning this to libccs, as it seems to be looping in ccs_force_connect()
Comment 2 Corey Marthaler 2004-11-18 18:58:47 EST
*** Bug 139975 has been marked as a duplicate of this bug. ***
Comment 3 Jonathan Earl Brassow 2004-12-15 15:09:32 EST
This should be fixed now.

The problem was that the library was thinking that ECONNREFUSED meant
that the privilaged port it was trying to use was busy.  This made the
library continue to check all ports with a back-off (sleep) between
each one - causing the process to appear hung.
Comment 4 Corey Marthaler 2004-12-20 15:32:51 EST
fix verified.

Note You need to log in before you can comment on or make changes to this bug.