Bug 139773 - Eclipse fails to find java.lang.Object when using IBM jvm
Eclipse fails to find java.lang.Object when using IBM jvm
Status: CLOSED WONTFIX
Product: Red Hat Developer Suite
Classification: Retired
Component: JDT (Show other bugs)
2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 17:56 EST by Ben Konrath
Modified: 2007-04-25 11:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 11:49:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
eclipse.org JRE System Library (198.16 KB, image/png)
2004-11-22 13:09 EST, Ben Konrath
no flags Details
RHDS JRE System Library (132.92 KB, image/png)
2004-11-22 13:11 EST, Ben Konrath
no flags Details

  None (edit)
Description Ben Konrath 2004-11-17 17:56:55 EST
Steps to Reproduce:

* make sure you only have the IBM jvm installed and it is listed as an 
  installed JRE
* import a java project from cvs

At this point Eclipse tries to compile the project but fails with this
message: 

The project was not built since its build path is incomplete. Cannot
find the class file for java.lang.Object. Fix the build path then try
building this project

To fix this, right click on the project -> Properties -> Java Build
Path -> Libraries tab -> Add External JARs ... -> select core.jar

I've seen this both on x386 and on ia64 with Java projects and plugin
projects.
Comment 1 Ben Konrath 2004-11-17 18:08:30 EST
Java packages installed on ia64: 

% rpm -qa | grep java-1.4.2
java-1.4.2-ibm-devel-1.4.2.0-1jpp_13rh
java-1.4.2-ibm-src-1.4.2.0-1jpp_13rh
java-1.4.2-ibm-1.4.2.0-1jpp_13rh
java-1.4.2-ibm-demo-1.4.2.0-1jpp_13rh
%
Comment 2 Ben Konrath 2004-11-22 13:04:23 EST
T've noticed that this happens for other jars in the JRE as well. The
attachments below show the JRE System Libraries for both RHDS and
eclipse from eclipse.org on the same machine with the same project.

Notice that the eclipse.org version has a more complete JRE System
Library.
Comment 3 Ben Konrath 2004-11-22 13:09:45 EST
Created attachment 107209 [details]
eclipse.org JRE System Library
Comment 4 Ben Konrath 2004-11-22 13:11:04 EST
Created attachment 107210 [details]
RHDS JRE System Library
Comment 5 Ben Konrath 2007-04-25 11:48:51 EDT
Closing bug as we are no longer working on RHDS 2.0.

Note You need to log in before you can comment on or make changes to this bug.