Bug 139783 - lynx crashes on http://www.digitaldeals.net/
lynx crashes on http://www.digitaldeals.net/
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lynx (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 19:53 EST by Need Real Name
Modified: 2009-11-25 07:28 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 08:02:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-11-17 19:53:25 EST
Description of problem:
Trying to go to the above site crashes lynx (SIGSEGV).

Version-Release number of selected component (if applicable):
2.8.5-18

How reproducible:
Always.

Steps to Reproduce:
1. lynx www.digitaldeals.net
2. observe crash
3.
  
Actual results:
A Fatal error has occurred in Lynx Ver. 2.8.5dev.16

Please notify your system administrator to confirm a bug, and
if confirmed, to notify the lynx-dev list.  Bug reports should
have concise descriptions of the command and/or URL which causes
the problem, the operating system name with version number, the
TCPIP implementation, and any other relevant information.

Do NOT mail the core file if one was generated.

Lynx now exiting with signal:  11

Aborted

Expected results:
No crash.

Additional info:
The same also happens on FC2's 2.8.5-15 build.

I am not sure what the cause is, maybe it has something to do with a
"503 Service Temporarily Unavailable" sent from the server?

$ wget -O /dev/null www.digitaldeals.net
--19:52:15--  http://www.digitaldeals.net/
           => `/dev/null'
Resolving www.digitaldeals.net... 69.93.139.66
Connecting to www.digitaldeals.net[69.93.139.66]:80... connected.
HTTP request sent, awaiting response... 503 Service Temporarily
Unavailable
19:52:15 ERROR 503: Service Temporarily Unavailable.

OpenBSD's "Lynx Version 2.8.5rel.2 (22 Apr 2004)" does not crash with
this site.

Also, here is a gdb backtrace, but it doesn't look very useful:

Program received signal SIGSEGV, Segmentation fault.
0x080b0ad2 in ?? ()
(gdb) bt
#0  0x080b0ad2 in ?? ()
#1  0x082cb968 in ?? ()
#2  0xfeffe338 in ?? ()
#3  0x00000001 in ?? ()
#4  0x00000001 in ?? ()
#5  0x00000000 in ?? ()

Thanks.
Comment 2 Tim Waugh 2004-11-19 08:02:27 EST
Fixed in 2.8.5-19.
Comment 3 Need Real Name 2005-03-02 18:29:23 EST
Tim,

thanks for updating this package.  Any chance of getting it pulled up
to FC3?
Comment 4 Tim Waugh 2005-03-10 08:44:56 EST
Not really at the moment -- too much FC4 work. :-/
Comment 5 jeje22 2009-11-25 07:28:57 EST
 its fixed


<a href="http://couponsdeals2u.com/">deals</a> <a href="http://couponsdeals2u.com/">coupons</a> <a href="http://couponsdeals2u.com/">shopping</a>

Note You need to log in before you can comment on or make changes to this bug.