Bug 139798 - mpage + ttfonts-ja == ghostscript undefinedresource unijis
mpage + ttfonts-ja == ghostscript undefinedresource unijis
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ttfonts-ja (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
:
: 142292 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 22:45 EST by Keith Owens
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.2-36.FC3.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 13:37:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Owens 2004-11-17 22:45:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
ghostscript-7.07-33
gv-3.5.8-29
mpage-2.5.4-2
ttfonts-ja-1.2-36

# date | mpage > x.ps

mpage generates these lines:

  /kanj /Ryumin-Light-H findfont 11 scalefont def
  /han /Ryumin-Light.Hankaku findfont 11 scalefont def
  /unijis /Ryumin-Light-UniJIS-UTF8-H findfont 11 scalefont def
  /uniks /Baekmuk-Batang-UniKS-UTF8-H findfont 11 scalefont def
  /unigb /BousungEG-Light-GB-UniGB-UTF8-H findfont 11 scalefont def
  /unicns /ShanHeiSun-Light-UniCNS-UTF8-H findfont 11 scalefont def

# gv x.ps

    Error: /undefinedresource in --findresource--
  Operand stack:
     unijis   Ryumin-Light-UniJIS-UTF8-H Font Ryumin-Light-UniJIS-UTF8-H
     (Ryumin-Light-UniJIS-UTF8-H) 12 Ryumin-Light UniJIS-UTF8-H
     UniJIS-UTF8-H --dict:0/10(G)-- Ryumin-Light false Ryumin-Light
     Ryumin-Light CIDFont --nostringval-- CMap CIDFont CMap CIDFont
  Execution stack:
     %interp_exit   .runexec2 --nostringval-- --nostringval--
     --nostringval-- 2 %stopped_push --nostringval-- --nostringval--
     --nostringval-- false 1 %stopped_push 1 3 %oparray_pop 1 3
     %oparray_pop 1 3 %oparray_pop 1 3 %oparray_pop .runexec2
     --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push
     --nostringval-- 2 3 %oparray_pop 3 3 %oparray_pop --nostringval--
     --nostringval-- 16 4 %oparray_pop --nostringval-- 19 5 %oparray_pop
     --nostringval-- --nostringval-- --nostringval-- --nostringval--
  Dictionary stack:
     --dict:1061/1123(ro)(G)--   --dict:0/20(G)-- --dict:100/200(L)--
     --dict:17/17(ro)(G)-- --dict:0/10(L)-- --dict:16/24(ro)(G)--
  Current allocation mode is local
  Last OS error: 2
  GNU Ghostscript 7.07: Unrecoverable error, exit code 1

ghostscript ignores all of the fonts, except for /unijis.
If ttfonts-ja is installed (it is used by MagicPoint) then
ghostscript breaks with the above traceback.  strace around the
failure shows 
 
stat64("/usr/share/ghostscript/Resource/Font/Ryumin-Light-UniJIS-UTF8-H",
0xbfffe2cc) = -1 ENOENT (No such file or directory)
  open("./Ryumin-Light-UniJIS-UTF8-H", O_RDONLY) = -1 ENOENT (No such
file or directory)
  open("/usr/share/ghostscript/7.07/lib/Ryumin-Light-UniJIS-UTF8-H",
O_RDONLY) = -1 ENOENT (No such file or directory)
  open("/usr/share/ghostscript/7.07/vflib/Ryumin-Light-UniJIS-UTF8-H",
O_RDONLY) = -1 ENOENT (No such file or directory)
  open("/usr/share/ghostscript/fonts/Ryumin-Light-UniJIS-UTF8-H",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/fonts/default/ghostscript/Ryumin-Light-UniJIS-UTF8-H",
O_RDONLY) = -1 ENOENT (No such file or directory)
  open("/usr/share/fonts/default/Type1/Ryumin-Light-UniJIS-UTF8-H",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/fonts/default/amspsfnt/pfb/Ryumin-Light-UniJIS-UTF8-H",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/fonts/default/cmpsfont/pfb/Ryumin-Light-UniJIS-UTF8-H",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/ghostscript/Resource/CIDFont/Ryumin-Light-UniJIS-UTF8",
O_RDONLY) = -1 ENOENT (No such file or directory)
  open("/usr/share/ghostscript/Resource/CIDFont/Ryumin-Light-UniJIS",
O_RDONLY) = -1 ENOENT (No such file or directory)
  open("/usr/share/ghostscript/Resource/CIDFont/Ryumin-Light",
O_RDONLY) = -1 ENOENT (No such file or directory)
  open("/usr/share/ghostscript/Resource/CIDFont/Kochi-Mincho",
O_RDONLY) = -1 ENOENT (No such file or directory)
  open("/usr/share/fonts/ja/TrueType/kochi-mincho-subst.ttf",
O_RDONLY) = 8
  fstat64(8, {st_mode=S_IFREG|0644, st_size=8941256, ...}) = 0
  fstat64(8, {st_mode=S_IFREG|0644, st_size=8941256, ...}) = 0
  mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0xb7fe4000
  _llseek(8, 0, [0], SEEK_CUR)      = 0
  _llseek(8, 0, [0], SEEK_SET)      = 0
  read(8, "\0\1\0\0\0\21\1\0\0\4\0\20EBDTF0\355P\0_e\350\0\33\376"...,
4096) = 4096
  ..... more reads removed .....
  read(8, "ppa\6Lambda\2Mu\2Nu\2Xi\7Omicron\2Pi\3R"..., 28672) = 28672
  read(8, "ni57DF\7uni57E0\7uni57E1\7uni57E3\7u"..., 4096) = 4096
  read(8, "ni5B89\7uni5B8A\7uni5B8B\7uni5B8C\7u"..., 28672) = 28672
  read(8, "ni7313\7uni7316\7uni7317\7uni7318\7u"..., 4096) = 4096
  read(8, "ni7644\7uni7645\7uni7646\7uni7647\7u"..., 28672) = 28672
  read(8, "ni8E92\7uni8E93\7uni8E94\7uni8E95\7u"..., 4096) = 4096
  read(8, "ni91CB\7uni91CC\7uni91CD\7uni91CE\7u"..., 20480) = 20480
  read(8, "uni3055.vert\funi3056.vert\funi305"..., 4096) = 3784
  open("/usr/share/ghostscript/Resource/CMap/CIDFont", O_RDONLY) = -1
ENOENT (No such file or directory)
  fstat64(1, {st_mode=S_IFIFO|0600, st_size=0, ...}) = 0
  mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0xb7fe6000
  write(1, "Error: /undefinedresource", 25 <unfinished ...>
  3502  <... select resumed> )            = 1 (in [7])
  <... write resumed> )             = 25

If I remove the ttfonts-ja package then ghostscript works fine on
mpage output.


Version-Release number of selected component (if applicable):
ghostscript-7.07-33

How reproducible:
Always

Steps to Reproduce:
1. Install ttfonts-ja
2. date | mpage > x.ps
3. gv x.ps
    

Actual Results:  gv (ghostscript) breaks with
Error: /undefinedresource in --findresource--
Operand stack:
   unijis   Ryumin-Light-UniJIS-UTF8-H Font Ryumin-Light-UniJIS-UTF8-H
   (Ryumin-Light-UniJIS-UTF8-H) 12 Ryumin-Light UniJIS-UTF8-H
   UniJIS-UTF8-H --dict:0/10(G)-- Ryumin-Light false Ryumin-Light
   Ryumin-Light CIDFont --nostringval-- CMap CIDFont CMap CIDFont


Expected Results:  Display the date as a Postscript file.

Additional info:

Uninstall ttfonts-ja and gv/ghostscript work again.
Comment 1 Tim Waugh 2004-12-02 12:34:05 EST
tagoh: any idea what's going on here?
Comment 2 Akira TAGOH 2004-12-03 00:43:45 EST
Argh, it seems that kochi-mincho-subst.ttf was broken since I modified it with
fontforge. something is wrong on ttfonts-ja side. I'll reassigning this to
ttfonts-ja then.
Comment 3 Tim Waugh 2004-12-09 07:27:03 EST
*** Bug 142292 has been marked as a duplicate of this bug. ***
Comment 4 Akira TAGOH 2004-12-09 13:37:50 EST
An updated package is available for FC3
Comment 5 Hardy Mayer 2004-12-09 17:19:37 EST
ttfonts-ja-1.2-36.FC3.0.noarch.rpm does not fix this bug!
Comment 6 Hardy Mayer 2004-12-09 17:26:18 EST
Sorry, I was wrong;  I di a clean reinstall of 
ttfonts-ja-1.2-36.FC3.0.noarch.rpm 
and now mpage and ps2pdf work again (although mpage turns the text
upside down, but I can live with this, since I use it only for printing).

Arigato, Akira. 

Note You need to log in before you can comment on or make changes to this bug.