Bug 139817 - the gnutls-devel package has no dependency on libgcrypt-devel
the gnutls-devel package has no dependency on libgcrypt-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnutls (Show other bugs)
3
All Linux
medium Severity low
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 03:27 EST by Philip Van Hoof
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-23 08:02:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Van Hoof 2004-11-18 03:27:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
It looks like the gnutls-devel package has no dependency on
libgcrypt-devel. Building applications that require gnutls, however,
seems to use -lgcrypt, for which you need libgcrypt-devel.


Version-Release number of selected component (if applicable):
gnutls-devel-1.0.20-3 libgcrypt-devel-1.2.0-3

How reproducible:
Always

Steps to Reproduce:
1. Build evolution-data-server from cvs
2. the configure script succeeds (as it found gnutls)
3. the make step fails (about -lgcrypt)
    

Actual Results:  the make step fails (about -lgcrypt)

Expected Results:  The configure script should have failed if
gnutls-devel was not installed or installing the package gnutls-devel
should have failed if libgcrypt-devel isn't installed.

Additional info:

http://lists.ximian.com/archives/public/evolution-hackers/2004-November/004730.html
Comment 1 Ivana Varekova 2004-11-23 08:02:32 EST
Fixed in newer release.
Thank you.
Ivana Varekova

Note You need to log in before you can comment on or make changes to this bug.