Bug 139820 - usermount doesn't work together with fstab-sync (hal)
usermount doesn't work together with fstab-sync (hal)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
: 141041 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 04:05 EST by Jiri Cerny
Modified: 2013-07-02 19:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.76-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-02 08:26:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jiri Cerny 2004-11-18 04:05:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
After upgrade from FC2 to FC3 the usermount tool stopped to work.
Message box "You have no right to mount any device, contact your
system administrator" appears when usermount is invoked even by the
console user. It can be corrected by adding "owner" to e.g. floppy
(which is not mounted automatically as CDs) entry in /etc/fstab, but
this file is overwriten by hal/fstab-sync during the next reboot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.upgrade FC2->FC3
2.reboot
3.start usermount
    

Additional info:
Comment 1 Jindrich Novy 2004-11-18 05:28:38 EST
Hello Jiri,

I think this problem has more to do with hal than with usermount since
hal was introduced with FC3 and wasn't present in FC2 where usermount
worked fine.

Reassigning to hal maintainer.

greetings,
Jindrich
Comment 2 David Zeuthen 2004-11-18 10:13:58 EST
Hi,

It seems that usermount needs to cope with the fact that the option
'pamconsole' is used instead of the option 'user'. The reason for this
is enhanced security. Note that 'pamconsole' has the same meaning as
'user' except that only an authorized user at the console is allowed
to mount the media. So you might also want to check that the user is
at the console if you don't already. Reassigning back to usermode.

Cheers,
David
Comment 3 Jindrich Novy 2004-11-25 05:03:48 EST
Fixed in CVS.
Comment 4 Jindrich Novy 2004-11-28 15:31:16 EST
*** Bug 141041 has been marked as a duplicate of this bug. ***
Comment 5 Jiri Cerny 2004-11-30 09:25:13 EST
I did not find a way how to access fedora cvs. Would it be possible to
post a patch or a link to the corrected version. 
Comment 6 Jindrich Novy 2004-12-02 08:26:55 EST
Jiri, I just built the new usermode release. You can get the rpm
before it appears at mirrors from:

http://people.redhat.com/jnovy/files/

Note You need to log in before you can comment on or make changes to this bug.