Bug 139822 - Error: missing dep: libdb_cxx-4.2.so for pkg openoffice.org-libs
Summary: Error: missing dep: libdb_cxx-4.2.so for pkg openoffice.org-libs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-18 09:58 UTC by Okke Timm
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-02 18:05:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Okke Timm 2004-11-18 09:58:06 UTC
Description of problem:
Error: missing dep: libdb_cxx-4.2.so for pkg openoffice.org-libs

Version-Release number of selected component (if applicable):
openoffice.org-libs-1.1.2-10

How reproducible:
Always

Steps to Reproduce:
1. yum update

Comment 1 John Thacker 2004-11-18 15:51:30 UTC
This is the same problem is 139527, just from the other way around
with db4 installed first and attempting to install OO.o-libs later.

Comment 2 Dan Williams 2004-12-02 18:05:51 UTC
Hmm, should be fixed in rawhide where we now build against db4-4.3

Comment 3 Daniel L. Rall 2005-02-14 23:22:46 UTC
*** Bug 148028 has been marked as a duplicate of this bug. ***

Comment 4 Daniel L. Rall 2005-02-15 01:06:09 UTC
I can confirm that the RawHide packages fix this problem for me,
allowing me to have the following installed concurrently:

openoffice.org-1.1.3-6.7.0
openoffice.org-i18n-1.1.3-6.7.0
openoffice.org-libs-1.1.3-6.7.0
db4-devel-4.3.21-1
db4-utils-4.3.21-1
db4-4.3.21-1
compat-db-4.2.52-2


$ for rpm in
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/openoffice.org-1.1.3-6.7.0.i386.rpm
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/openoffice.org-i18n-1.1.3-6.7.0.i386.rpm
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/openoffice.org-libs-1.1.3-6.7.0.i386.rpm;
do wget $rpm; done; unset rpm
$ sudo rpm -Uv openoffice.org-*.rpm


Note You need to log in before you can comment on or make changes to this bug.