Bug 139826 - unable to print bitmap glyphs (when the string contains ASCII chars)
unable to print bitmap glyphs (when the string contains ASCII chars)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgnomeprint22 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 05:22 EST by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 06:10:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample text file which contain both TC chars and ASCII in a string (40 bytes, text/plain)
2004-11-18 05:22 EST, Lawrence Lim
no flags Details

  None (edit)
Description Lawrence Lim 2004-11-18 05:22:10 EST
Description of problem:
When TC characters and ASCII characters are mixed in a string, the TC cannot be
printed. 

I have attached a text file which I hope can assist you in testing.

Version-Release number of selected component (if applicable):
libgnomeprint22-2.8.0-2

How reproducible:
Always

Steps to Reproduce:
1.Log in zh_TW (Traditional Chinese) from gdm
2.open gedit.txt with gedit
3.print the document
  
Actual results:
only ASCII characters are printed

Expected results:
everything should be printed

Additional info:
Comment 1 Lawrence Lim 2004-11-18 05:22:11 EST
Created attachment 106946 [details]
sample text file which contain both TC chars and ASCII in a string
Comment 2 Leon Ho 2004-11-18 06:43:53 EST
Seems all those "『』,。:;?()" have changed to bitmap font
(related to bug 129541) after typed in "a", and seems libgnomeprint
cannot print out those bitmap glyphs. The overall sounds related to
bug 138783, so it is not only related to TC.
Comment 3 Leon Ho 2005-05-10 02:24:43 EDT
Look like it is fixed upstream and package are in FC4.
Comment 4 Lawrence Lim 2005-05-10 02:51:43 EDT
Unfortunately, the bug still exist. Tested with libgnomeprint22-2.10.1-3.
Comment 5 Lawrence Lim 2005-05-10 03:05:06 EDT
[root@scarecrow ~]# rpm -qa |grep fonts-
kon2-fonts-0.3.9b-26
fonts-gujarati-1.9-2
fonts-xorg-ISO8859-2-75dpi-6.8.2-1
fonts-ISO8859-2-75dpi-1.0-14
fonts-tamil-1.9-2
fonts-xorg-75dpi-6.8.2-1
fonts-xorg-cyrillic-6.8.2-1
tetex-fonts-3.0-3
fonts-KOI8-R-1.0-7
fonts-xorg-ISO8859-15-100dpi-6.8.2-1
urw-fonts-2.3-1
bitstream-vera-fonts-1.10-5
fonts-ISO8859-2-100dpi-1.0-14
fonts-arabic-1.5-3
fonts-xorg-ISO8859-14-75dpi-6.8.2-1
ghostscript-fonts-5.50-13
taipeifonts-1.2-26
fonts-KOI8-R-75dpi-1.0-7
fonts-bengali-1.9-2
fonts-xorg-ISO8859-2-100dpi-6.8.2-1
fonts-xorg-ISO8859-9-100dpi-6.8.2-1
fonts-punjabi-1.9-2
bitmap-fonts-cjk-0.3-4
fonts-xorg-ISO8859-15-75dpi-6.8.2-1
bitmap-fonts-0.3-4
fonts-xorg-100dpi-6.8.2-1
fonts-ISO8859-2-1.0-14
fonts-korean-1.0.11-4
fonts-hebrew-0.100-4
fonts-xorg-syriac-6.8.2-1
fonts-chinese-2.15-2
fonts-KOI8-R-100dpi-1.0-7
fonts-xorg-base-6.8.2-1
fonts-xorg-ISO8859-14-100dpi-6.8.2-1
fonts-japanese-0.20050222-3
fonts-xorg-truetype-6.8.2-1
fonts-xorg-ISO8859-9-75dpi-6.8.2-1
fonts-hindi-1.9-2
Comment 6 Leon Ho 2005-05-10 03:22:03 EDT
Okay. It should be because i haven't got taipeifonts.

fonts-hindi-1.9-2
fonts-korean-1.0.11-4
fonts-xorg-ISO8859-14-75dpi-6.8.2-1
urw-fonts-2.3-1
fonts-arabic-1.5-3
fonts-ISO8859-2-75dpi-1.0-14
fonts-xorg-100dpi-6.8.2-1
fonts-xorg-ISO8859-2-100dpi-6.8.2-1
fonts-xorg-truetype-6.8.2-1
fonts-gujarati-1.9-2
fonts-ISO8859-2-1.0-14
fonts-KOI8-R-1.0-7
fonts-tamil-1.9-2
fonts-xorg-cyrillic-6.8.2-1
fonts-xorg-ISO8859-15-75dpi-6.8.2-1
fonts-xorg-ISO8859-9-75dpi-6.8.2-1
bitstream-vera-fonts-1.10-5
tetex-fonts-3.0-3
fonts-chinese-2.15-2
fonts-ISO8859-2-100dpi-1.0-14
fonts-KOI8-R-100dpi-1.0-7
fonts-punjabi-1.9-2
fonts-xorg-base-6.8.2-1
fonts-xorg-ISO8859-15-100dpi-6.8.2-1
fonts-xorg-ISO8859-9-100dpi-6.8.2-1
ghostscript-fonts-5.50-13
bitmap-fonts-0.3-4
fonts-bengali-1.9-2
fonts-japanese-0.20050222-3
fonts-xorg-75dpi-6.8.2-1
fonts-xorg-ISO8859-2-75dpi-6.8.2-1
fonts-hebrew-0.100-4
fonts-KOI8-R-75dpi-1.0-7
fonts-xorg-ISO8859-14-100dpi-6.8.2-1
fonts-xorg-syriac-6.8.2-1
Comment 7 Lawrence Lim 2005-05-10 03:38:34 EDT
Aha. I did a full installation with LANG=zh_TW.
Comment 8 Akira TAGOH 2005-09-28 06:35:01 EDT
The testcase works for me with the following packages on rawhide:

gedit-2.12.0-1
libgnomeprint22-2.12.0-1
libgnomeprintui22-2.12.0-1
pango-1.10.0-1
freetype-2.1.9-4

However after modifying .fonts.conf to enforce the bitmap fonts, it doesn't work
then. is it the expected behavior or a bug?
Comment 9 Akira TAGOH 2006-09-13 04:06:48 EDT
Lawrence, does this still happen in rawhide? taipeifonts package isn't available
anymore and I'm wondering if there are any ways to reproduce.
Comment 10 Leon Ho 2006-09-28 01:31:06 EDT
taipeifonts is merged into fonts-chinese. Can you reproduce with it?
Comment 11 Akira TAGOH 2006-09-28 02:47:38 EDT
No, I don't think so I have fonts-chinese installed and tested on Chinese
locales since any Chinese locales are required for testing.

changing the status to MODIFIED once. please confirm a fix.
Comment 12 Xiaohong Wang 2006-09-29 03:28:52 EDT
Tried to verify this bug, but in latest FC6, there are print problem. 
Bug 208240, 208239
Comment 13 A S Alam 2007-05-21 06:10:58 EDT
it was working with following version:
libgnomeprint22-2.18.0-1.fc7

Note You need to log in before you can comment on or make changes to this bug.