Bug 139828 - libcapi20 incompatible with device naming in /dev
libcapi20 incompatible with device naming in /dev
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: isdn4k-utils (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 05:35 EST by Tomasz Kepczynski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 10:42:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomasz Kepczynski 2004-11-18 05:35:33 EST
Description of problem:
capiinfo reports that no capi driver is installed contrary to
what is in the system.
The problem is related to changes in /dev/capi* nodes naming
in kernel (udev???) which where not introduced to libcapi20.
The following whould be changed:
/dev/capi20 -> /dev/capi
/dev/capi20.* - remove
/dev/capi/%n -> /dev/capi%n (not sure about it, makes capifs
obsolete???)
Now, these are my guesses after analyzing some code in isdn4k-utils
and actual /dev/capi* nodes created by udev-0.44 (0.39 does not
support capi!).

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. install isdn card and capi driver for it
2. run capiinfo
3. no such node returned due to wrong /dev/capi20 major and minor
  
Actual results:
capi does not work

Expected results:
capi works

Additional info:
This should be really coordinated between kernel, udev and
isdn4k-utils!
The above are my guesses and I may be wrong about what's correct
and what's not.
isdn4k-utils in rpm are awfully old (over a year).
Comment 1 Ngo Than 2004-11-18 10:42:04 EST
it's a problem a kernel and udev. kernel isdn driver should provide
the info to udev for creating devices by loading of isdn module.

I now added a workaround in isdn4k-utils, which creates devices if it
does not exist. we already have similar bug report on kernel.

i will build isdn4k-utils-3.2-19, which has the current isdn4k-utils
snapshot from today, in rawhide today. Many thanks for your report.
Comment 2 Maarten Bremer 2005-03-04 06:49:03 EST
This bug is a duplicate of bug 139321.

The problem is solved for isdn4k-utils, but it is still open for
capi4linux. 

A workaround has been given on
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=139321 by Alain
Richard and a technical explaination has been given by Herbert on
http://www.friendglow.net/en/faq/faq_kernel26_udev_en.shtml.

Please fix the problem for real, instead of making workarounds.

Note You need to log in before you can comment on or make changes to this bug.