Bug 139866 - rsh -d doesn't do anything
rsh -d doesn't do anything
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rsh (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 10:39 EST by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 05:25:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2004-11-18 10:39:27 EST
# rsh -d 172.31.0.52 uname -a
Linux 172.31.0.52 2.4.21-20.ELsmp #1 SMP Wed Aug 18 20:46:40 EDT 2004
i686 i686 i386 GNU/Linux
# rsh 172.31.0.52 uname -a
Linux 172.31.0.52 2.4.21-20.ELsmp #1 SMP Wed Aug 18 20:46:40 EDT 2004
i686 i686 i386 GNU/Linux

No difference at all...

# rpm -q rsh
rsh-0.17-17
Comment 1 Radek Vokal 2004-11-18 10:43:53 EST
And what is your expected result for this? 
Comment 2 Bastien Nocera 2004-11-18 11:02:58 EST
I have absolutely no idea...
Comment 3 Karel Zak 2004-11-22 13:50:37 EST
-d means socket debugging. You have to use it with something other,
for example: rsh -d <host> <command>

It works for me.

If you haven't idea I have one nice idea -- I'm going to close this
report as Not A Bug :-)
Comment 4 Bastien Nocera 2004-11-25 04:41:44 EST
What's the difference between:
rsh -d <host> <command>
and
rsh -d 172.31.0.52 uname -a
?

If you do get some debugging, how come no debugging output is coming
on my tests?
Comment 5 Bastien Nocera 2004-11-25 04:44:57 EST
By the way, although I don't know what the output will look like, I do
expect some difference in the output if I use the "-d" switch...
Comment 6 Karel Zak 2004-11-25 05:23:16 EST
-d option set secket to debug mode by setsockopt(). It's all. It
hasn't other effect to rsh. It means rsh doesn't output any extra
messages for "-d", so it's wrong if you expect any difference in the
output. 

The socket debug messages are out of rsh control. All control of this
stuff has linux kernel. The output of kernel messages maintain klogd
and syslogd and depend on your system setting what and where (on
console or in the /var/log/messages) you will see.
Comment 7 Bastien Nocera 2004-11-25 05:25:09 EST
Ha, understood. Thanks for the clarification.

Note You need to log in before you can comment on or make changes to this bug.