This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 139868 - p570 does not boot from CD, hangs on ide lost interrupt
p570 does not boot from CD, hangs on ide lost interrupt
Status: CLOSED DUPLICATE of bug 128790
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: David Howells
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 10:41 EST by Chris Read
Modified: 2007-11-30 17:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Read 2004-11-18 10:41:22 EST
Description of problem:

When booting off of CD1 or the included pseries boot CD on IBM p570
machine from internal IDE DVD drive, the kernel boots, but hangs with
the message:

ide: lost interrupt

Version-Release number of selected component (if applicable):



How reproducible: Every time


Steps to Reproduce:
1. Insert CD 1 or pseries boot CD into DVD drive
2. Assign DVD drive to LPAR, boot into SMS mode
3. Select boot from CD

  
Actual results: 

Hangs at ide lost interrupt

Expected results:

Boot into installer

Additional info:
Comment 1 David Howells 2004-11-19 09:50:56 EST
Can you get the kernel log? 
 
What's a p570? A power5 box? 
Comment 3 Chris Read 2004-11-20 16:40:15 EST
Greetings...

Will try to get a kernel log monday morning at work.

It's one of the new IBM Power5 machines. http://www-
1.ibm.com/servers/eserver/pseries/hardware/midrange/570.html

Chris
Comment 4 Chris Read 2004-11-24 04:24:25 EST
Greetings, here's the full kernel output up until hang time:

--- SNIP ---

Welcome to yaboot version 1.3.12
Enter "help" to get some basic usage information
boot: linux
Please wait, loading kernel...
   Elf64 kernel loaded...
Loading ramdisk...
ramdisk loaded at 02300000, size: 3692 Kbytes
OF stdout device is: /vdevice/vty@30000000
Hypertas detected, assuming LPAR !
command line: ro maxcpus=1 
memory layout at init:
  alloc_bottom : 000000000269c000
  alloc_top    : 0000000008000000
  alloc_top_hi : 0000000100000000
  rmo_top      : 0000000008000000
  ram_top      : 0000000100000000
Looking for displays
instantiating rtas at 0x00000000077d9000... done
0000000000000000 : boot cpu     0000000000000000
0000000000000002 : starting cpu hw idx 0000000000000002... done
copying OF device tree ...
Building dt strings...
Building dt structure...
Device tree strings 0x000000000279d000 -> 0x000000000279e177
Device tree struct  0x000000000279f000 -> 0x00000000027a9000
Calling quiesce ...
returning from prom_init
Found initrd at 0xc000000002300000:0xc00000000269b369
firmware_features = 0x1ffd5f
Partition configured for 40 cpus.
Starting Linux PPC64 2.6.9-1.648_EL
-----------------------------------------------------
naca                          = 0xc000000000004000
naca->pftSize                 = 0x1a
naca->debug_switch            = 0x0
naca->interrupt_controller    = 0x2
systemcfg                     = 0xc000000000005000
systemcfg->processorCount     = 0x4
systemcfg->physicalMemorySize = 0x100000000
systemcfg->dCacheL1LineSize   = 0x80
systemcfg->iCacheL1LineSize   = 0x80
htab_data.htab                = 0x0000000000000000
htab_data.num_ptegs           = 0x80000
-----------------------------------------------------
[boot]0100 MM Init
[boot]0100 MM Init Done
Linux version 2.6.9-1.648_EL (bhcompile@cure81.build.redhat.com) (gcc
version 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)) #1 SMP Tue Oct 26
12:14:21 EDT 2004
[boot]0012 Setup Arch
Node 0 CPUs: 0-39
Node 1 CPUs:
Node 0 Memory: 0x0-0x84000000
Node 1 Memory: 0x84000000-0x100000000
Using dedicated idle loop
0000000000000001 : starting thread
0000000000000003 : starting thread
EEH: PCI Enhanced I/O Error Handling Enabled
PPC64 nvram contains 7168 bytes
[boot]0015 Setup Done
Built 2 zonelists
Kernel command line: ro maxcpus=1 
[boot]0020 XICS Init
xics: no ISA interrupt controller
[boot]0021 XICS Done
PID hash table entries: 4096 (order: 12, 131072 bytes)
time_init: decrementer frequency = 238.059000 MHz
time_init: processor frequency   = 1904.472000 MHz
Found initrd at 0xc000000002300000:0xc00000000269b369
firmware_features = 0x1ffd5f
Partition configured for 40 cpus.
Starting Linux PPC64 2.6.9-1.648_EL
-----------------------------------------------------
naca                          = 0xc000000000004000
naca->pftSize                 = 0x1a
naca->debug_switch            = 0x0
naca->interrupt_controller    = 0x2
systemcfg                     = 0xc000000000005000
systemcfg->processorCount     = 0x4
systemcfg->physicalMemorySize = 0x100000000
systemcfg->dCacheL1LineSize   = 0x80
systemcfg->iCacheL1LineSize   = 0x80
htab_data.htab                = 0x0000000000000000
htab_data.num_ptegs           = 0x80000
-----------------------------------------------------
[boot]0100 MM Init
[boot]0100 MM Init Done
Linux version 2.6.9-1.648_EL (bhcompile@cure81.build.redhat.com) (gcc
version 3.4.2 20041017 (Red Hat 3.4.2-6.fc3)) #1 SMP Tue Oct 26
12:14:21 EDT 2004
[boot]0012 Setup Arch
Node 0 CPUs: 0-39
Node 1 CPUs:
Node 0 Memory: 0x0-0x84000000
Node 1 Memory: 0x84000000-0x100000000
Using dedicated idle loop
0000000000000001 : starting thread
0000000000000003 : starting thread
EEH: PCI Enhanced I/O Error Handling Enabled
PPC64 nvram contains 7168 bytes
[boot]0015 Setup Done
Built 2 zonelists
Kernel command line: ro maxcpus=1 
[boot]0020 XICS Init
xics: no ISA interrupt controller
[boot]0021 XICS Done
PID hash table entries: 4096 (order: 12, 131072 bytes)
time_init: decrementer frequency = 238.059000 MHz
time_init: processor frequency   = 1904.472000 MHz
Console: colour dummy device 80x25
Dentry cache hash table entries: 1048576 (order: 11, 8388608 bytes)
Inode-cache hash table entries: 524288 (order: 10, 4194304 bytes)
freeing bootmem node 0
freeing bootmem node 1
Memory: 4102528k/4194304k available (2940k kernel code, 91136k
reserved, 1236k data, 516k bss, 212k init)
Security Scaffold v1.0.0 initialized
SELinux:  Initializing.
SELinux:  Starting in permissive mode
There is already a security framework initialized, register_security
failed.
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entries: 256 (order: 0, 4096 bytes)
Brought up 1 CPUs
checking if image is initramfs...it isn't (no cpio magic); looks like
an initrd
Freeing initrd memory: 3692k freed
Unable to get OpenPIC IRQ for cascade
NET: Registered protocol family 16
PCI: Probing PCI hardware
IOMMU table initialized, virtual merging enabled
PCI: Probing PCI hardware done
usbcore: registered new driver usbfs
usbcore: registered new driver hub
scan-log-dump not implemented on this system
audit: initializing netlink socket (disabled)
audit(1269754.255:0): initialized
RTAS daemon started
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
SELinux:  Registering netfilter hooks
Initializing Cryptographic API
ksign: Installing public key data
Loading keyring
- Added public key 1607E1E3F985E632
  - key was been created 1097537392 seconds in future
- User ID: Red Hat, Inc. (Kernel Module GPG key)
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
rpaphp: RPA HOT Plug PCI Controller Driver version: 0.1
rpaphp: register_vio_slot: registered VIO device[name=30000000
vio_dev=c000000083fdda00]
rpaphp: Slot [30000000](VIO location=U9117.570.651C4CE-V4-C0) registered
rpaphp: Slot [0000:00:02.2](PCI location=U7879.001.DQD0GA6-P1-T12)
registered
rpaphp: Slot [0000:00:02.4](PCI location=U7879.001.DQD0GA6-P1-T15)
registered
rpaphp: Slot [0000:00:02.0](PCI location=U7879.001.DQD0GA6-P1-C1)
registered
HVSI: registered 0 devices
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing enabled
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
Warning: no ADB interface detected
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with
idebus=xx
PDC20275: IDE controller at PCI slot 0000:d0:01.0
PDC20275: chipset revision 1
PDC20275: 100% native mode on irq 135
    ide2: BM-DMA at 0xeec00-0xeec07, BIOS settings: hde:DMA, hdf:DMA
    ide3: BM-DMA at 0xeec08-0xeec0f, BIOS settings: hdg:pio, hdh:pio
hde: IBM DROM00205, ATAPI CD/DVD-ROM drive
Using cfq io scheduler
ide2 at 0xee400-0xee407,0xedc02 on irq 135
ide-cd: cmd 0x5a timed out
hde: lost interrupt
ide-cd: cmd 0x5a timed out
hde: lost interrupt
hde: ATAPI 24X DVD-ROM drive, 256kB Cache
Uniform CD-ROM driver Revision: 3.20
hde: lost interrupt
ide-cd: cmd 0x25 timed out
hde: lost interrupt
ide-cd: cmd 0x25 timed out
hde: lost interrupt
hde: lost interrupt


--- SNIP ---

And it just sits there in a loop repeating the last line. Left it for
over an hour with no joy.

Chris

Comment 5 James Laska 2004-11-29 10:33:40 EST
Please retry while passing the boot argument "maxcpus=128" when you start the
installer from CD.  My suspicion is that this is bug#128790 (LTC10256).  If the
installation works with "maxcpus=128", then this issue will be CLOSED NOTABUG as
the root cause of bug#128790 is confirmed by IBM to be firmware related.
Comment 8 Doug Maxey 2004-11-30 11:02:00 EST
Is the partition reporting the problem not the primary (or original)
partition?  
Comment 9 Chris Read 2004-11-30 11:39:00 EST
Tried it on partitions 2, 4 and 5 with the same result. We're doing
other testing on the system with AIX so I can't take the box down and
do a whole machine test.
Comment 10 Doug Maxey 2004-11-30 11:52:24 EST
Which partition is running which OS?  All the same?  Mixed?

Well, the point I am trying to make is that although the HMC will let
you 'move' the ATAPI cdrom, it does not work.  There is WIP to allow
the cdrom to be 'hotplugged' as it were to move between partitions,
but that is not yet complete.
Comment 11 James Laska 2004-11-30 11:53:53 EST
Have you tried comment#5?  I have a nagging suspicion that this is a
known issue.
Comment 12 Chris Read 2004-11-30 11:58:02 EST
Not had a chance to try comment #5 yet, will get a chance next week
again. CD has not been 'hotplugged' between lpars, but attached as
'required' on in the IO profile.
Comment 15 mark wisner 2004-11-30 14:29:06 EST
Chris,

After talking with one of our HMC experts, he agrees with James'
comment that you need to use maxcpus=128.
Comment 16 Doug Maxey 2004-11-30 15:25:56 EST
Why thank you Mark!

One other point is that you *can* move the IDE device between
partitions, with the target having the device as 'required', then
rebooting both partitions.

This can also work when no partition has the device as 'required', but
in that case the first partition will get the device.  In this
scenario, both will have to be rebooted, with the part where the
device is needed is booted first.
Comment 21 Chris Read 2004-12-07 11:21:10 EST
Greetings all...

maxcpus=128 did the trick, thanks.

Chris
Comment 22 James Laska 2004-12-07 11:28:57 EST

*** This bug has been marked as a duplicate of 128790 ***
Comment 23 Red Hat Bugzilla 2006-02-21 14:07:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.