Bug 1398825 - Updating glibc in docker container causes locales to be unusable
Summary: Updating glibc in docker container causes locales to be unusable
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: glibc
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: glibc team
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-26 13:09 UTC by David
Modified: 2017-07-31 11:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-31 11:52:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1392855 None CLOSED build-locale-archive: build-locale-archive.c:301: fill_archive: Assertion `used < head->namehash_used' failed. 2019-03-25 07:34:28 UTC

Internal Links: 1392855

Description David 2016-11-26 13:09:40 UTC
Description of problem:
When updating a rhel 7.2 container to 7.3, the update of glibc and glibc common, cause the locales to become unusable.

Locale -a, lists only C and POSIX.

This breaks a number of web applications that depend on the server having access to the same locale as the client. I first discovered it with an owncloud container.

The locale files under /use/share/i18n do get installed, and permissions are correct on them.

The config file in /etc does show (in my case) en_US.UTF-8, but locale command shows its using POSIX.

Selinux on host shows no denials, labels on the locale files are correct.

To fix, have to do a localedef build on every language. Or downgrade the glibc and glibc-common packages
localedef -v -c -i en_US -f UTF-8 en_US.UTF-8 

This does also occur on centos 7.2 containers being updated to their CR version.

Version-Release number of selected component (if applicable):
glibc-2.17-157.el7.x86_64
glibc-common-2.17-157.el7.x86_64

How reproducible:
Upgrade existing container from 7.2 glibc packages, to the 7.3 versions.
Locale -a does not show locales except c and POSIX

Steps to Reproduce:
1.use existing rhel 7.2 container
2.upgrade glibc and glic-common to the 7.3 versions (and all other packages if desired)
3.do a locale -a, or utilize something dependant on another locale

Actual results:
Only c and POSIX work 

Expected results:
All locales work

Additional info:

Comment 1 Florian Weimer 2016-11-26 14:44:25 UTC
This is the intended behavior.  We wanted to make the container image locale removal persistent across updates.

Bug 1392855 comment 3 contains the steps required to obtain a full complement of locales.

I agree that this is a documentation issue.


Note You need to log in before you can comment on or make changes to this bug.