Bug 1398940 - beesu doesn't start in wayland
Summary: beesu doesn't start in wayland
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: beesu   
(Show other bugs)
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-27 13:36 UTC by Héctor Louzao
Modified: 2016-12-01 15:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-29 15:47:59 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Héctor Louzao 2016-11-27 13:36:10 UTC
Description of problem:

beesu doesn't start in wayland

Version-Release number of selected component (if applicable):

beesu-2.7-27.fc24.x86_64
nautilus-beesu-manager-1.8-27.fc24.noarch

How reproducible: always

Steps to Reproduce:

1. Install the previous packages
2. Open nautilus
3. select the directory to open with privileges options -> right click - select script - open nautilus here

another possible step to reproduce this behaviour is type in terminal :

beesu nautilus

I've get this error :

--------------------------------------------------------------

No protocol specified
Unable to init server: No se pudo conectar: Connection refused

(nautilus:10383): Gtk-WARNING **: cannot open display: :0

---------------------------------------------------------------

Actual results:

appears a windows to introduce the password and nothing happened

Expected results:

open nautilus as privileges access (root).

Additional info:

beesu script manager works as usual.

if very strange because the version is fc24. Is a fresh fedora install.

Regards.,

Comment 1 Tom "spot" Callaway 2016-11-29 15:47:59 UTC
This is an intentional design decision of wayland, see https://bugzilla.redhat.com/show_bug.cgi?id=1274451.

I'm going to retire beesu for a number of reasons, including upstream abandonment, but this is the final straw.

Comment 2 Ralf Senderek 2016-11-30 16:17:20 UTC
Hello Tom, 

do you know of a drop-in replacement for beesu that works under wayland?

Comment 3 Tom "spot" Callaway 2016-12-01 15:16:23 UTC
No. Read through 1274451 for the reasoning (and several workarounds to allow graphical apps to run via sudo).


Note You need to log in before you can comment on or make changes to this bug.