Bug 139939 - Missing ide-floppy device files
Missing ide-floppy device files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
: EasyFix
Depends On:
Blocks: 136971
  Show dependency treegraph
 
Reported: 2004-11-18 15:59 EST by David Zeuthen
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version: udev-039-10.FC3.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 13:09:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Zeuthen 2004-11-18 15:59:14 EST
Description of problem:

Device file not created for ide-floppy

Version-Release number of selected component (if applicable):

udev-039-10.FC3.1 and udev-042-1 (both FC3 latest and development)

How reproducible:

Always

Steps to Reproduce:
1. Actually test udev with an IDE drive using the ide-floppy driver.
Use an IDE Zip Drive for instance.
  
Actual results:

Device file is missing (in my case /dev/hdd)

Expected results:

Device file should be created

Additional info:

EasyFix; this line 

 KERNEL="hd[a-z]", BUS="ide", SYSFS{removable}="1",
PROGRAM="/etc/udev/scripts/ide-media.sh %k", RESULT="floppy",
SYMLINK="floppy%e

is missing a trailing "

Please fix this for both FC3 and devel as it is blocking bug 136971.

Thanks,
David
Comment 1 David Zeuthen 2004-12-02 17:17:50 EST
Actually, we also need NAME{all_partitions}="%k" in order to force
udev to create e.g. /dev/hdd4 - without this users will need to boot
with e.g. Zip media in the drive or manually do a 'blockdev --rereadpt
/dev/hdd'. To conclude, the line should be

 KERNEL="hd[a-z]", BUS="ide", SYSFS{removable}="1",
PROGRAM="/etc/udev/scripts/ide-media.sh %k", RESULT="floppy",
SYMLINK="floppy%e", NAME{all_partitions}="%k"

Since I've already fixed the hal parts for IDE Zip drives (in bug
136971), please provide this as a FC3 update so IDE Zip drives works
out of the box.

Thanks,
David

Note You need to log in before you can comment on or make changes to this bug.