Bug 139943 - Exchange calendar selection locks Evolution
Exchange calendar selection locks Evolution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 16:09 EST by Brendon Colby
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-09 09:31:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
9 last lines of stracing evolution when it hangs (708 bytes, text/plain)
2004-12-17 08:25 EST, Osmo Laitinen
no flags Details

  None (edit)
Description Brendon Colby 2004-11-18 16:09:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
My system is a FC2->FC3 upgrade. I had been running evolution 2 from
http://petrix.se/evolution2. The packages were successfully upgraded
with the FC3 packages. After upgrade, when I select my exchange
calendar, evolution locks up hard. I have to kill evolution and
evolution-exchange-storage and restart evolution three times before it
comes back up, with my exchange calendar unchecked.

Version-Release number of selected component (if applicable):
2.02-1

How reproducible:
Always

Steps to Reproduce:
1. Select Calendar area.
2. Tick box next to Exchange calendar.
3. Switch to a different area i.e. mail.
    

Actual Results:  Evolution locks up.

Expected Results:  Evolution should bring up my exchange calendar.

Additional info:
Comment 1 Osmo Laitinen 2004-12-16 08:47:11 EST
I can confirm this behavior. Althought my evolution has been working
ok till yesterday on FC3 (don't know what broke it, messed with my
/etc/sysconfig/i18n also, but replace the old one already).

I my case if I tick box next to Exchange calendar, the evolution hangs
and even after killing and restarting it hangs, since it tries to open
the calendar. 

Tried to fix with following devel-packages:
evolution-2.0.2-6.i386.rpm
evolution-connector-2.0.2-2.i386.rpm
evolution-data-server-1.0.2-6.i386.rpm

With these Evolution starts and works untill I tick box next to
Exchange calendar again.

and
evolution-2.0.3-1.i386.rpm
evolution-connector-2.0.3-1.i386.rpm
evolution-data-server-1.0.3-2.i386.rpm
but these don't allow me to log in anymore (see my comment on bug:
142927).

Comment 2 Osmo Laitinen 2004-12-17 08:25:56 EST
Created attachment 108789 [details]
9 last lines of stracing evolution when it hangs
Comment 3 Osmo Laitinen 2004-12-17 08:56:31 EST
I also made a fresh FC3 installation and tested with that (with and
without official updates), but the problem still occurs.
Since the calendar worked ok earlier, this seems quite strange...
Mail works, Global catalog works, but calendar does not.
Calendar works ok with web browser.
Comment 4 Daniel L. Rall 2005-01-31 14:32:24 EST
This issue is a showstopper for use of shared Exchange calendaring (my
primary use case for Evolution).

The symptoms reported here are very similar to the Evolution Exchange
calendar problem reported (and fixed last Friday) here:

http://bugzilla.ximian.com/show_bug.cgi?id=70357

This also sounds suspiciously close to bug 144072.

Here's the package list from one of the FC3 boxes I have which
experiences this problem:
evolution-2.0.2-6
evolution-connector-2.0.2-2
evolution-data-server-1.0.2-3
Comment 5 Osmo Laitinen 2005-01-31 16:35:33 EST
I almost have forgotten this (since I'm using web interface with
calendar).

I did some simple testing with other account (my colleague's) and it
did works fine with calendar. And I checked my exhange account and it
is ok, according to our Exchange staff... So this seems to be quite
bizzarre.
Comment 6 Daniel L. Rall 2005-01-31 18:38:28 EST
I initially had calendaring working myself, but it eventually stopped
working as a result of the upstream bug.  The web calendaring is used
by some of my colleagues, but is not a workable solution for me since
I do not use Exchange for email.  To deal with the high volume of mail
I receive, I have made a sizable investment in my own mail filtering
infrastructure (SpamAssassin/procmail/postfix/fetchmail), and POP mail
from all my accounts to deal with it in one place.  I have a sneaking
suspicion that the open source developers at RedHat can relate.  ;-)
Comment 7 Sean Bruno 2005-02-12 18:41:20 EST
Just a "me too" to this bug.  This seems to have come up in the last
few weeks while the Windows folks did a massive update to Active
Directory.  Any ideas on how to work around this one?
Comment 8 Sean Bruno 2005-02-12 19:40:32 EST
Well, this patch does indeed fix this issue:

http://bugzilla.ximian.com/showattachment.cgi?attach_id=13397

How about an updated RPM?  Thanks for the help!

Comment 9 Daniel L. Rall 2005-02-14 20:11:12 EST
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/
includes some Evolution RPMs dated Feb. 8 and 9.  Those may do the
trick...
Comment 10 Daniel L. Rall 2005-02-17 12:44:50 EST
The RPMs I referenced in comment #9 have -- so far -- fixed this
problem for me.  The upgrade introduced a couple of other minor UI
glitches, but removal of that showstopper bug was huge.  I'd say you
can mark this bug as FIXED or RAWHIDE now.  Thanks guys!
Comment 11 Dave Malcolm 2005-03-09 09:31:53 EST
Thanks for all the comments.

Resolving as RAWHIDE since comment #10 suggests it's fixed in the
Evolution 2.1/2.2 series; this will become part of FC4

I've also done test updates of Evolution 2.0.* packages
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/3/

From my reading of the upstream bug referenced in comment #4, this
should be fixed in those packages (specifically, the
evolution-connector-2.0.4-* packages)

Please reopen this bug if these packages don't fix the problem.

Note You need to log in before you can comment on or make changes to this bug.