Bug 139959 - Video driver broken when installing and running anything graphically
Video driver broken when installing and running anything graphically
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 17:22 EST by Brian P. Heffner
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 10:31:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian P. Heffner 2004-11-18 17:22:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Cannot run the installation CDs using the graphical installation.  The
screen cycles between black and a brief flicker of graphics.  It is
thoroughly unusable.  Can only install in text mode with the "nofb"
boot option.  Without the "nofb" option, the screen just goes black
and stays black.  Note that I can still interact with any running
application--it's just the screen that's hosed.  Once text-based
installation is up and running, installation proceeds ok, but XWindows
exhibits the exact same flickering problem when everything's done and
the system is rebooted.

Problem non-existent with FC2, which I am currently back to because
FC3 breaks my machine.

Hardware is a flat-screen LCD monitor, ATI Radeon 9600XT card.  The
installation probes the hardware, and indicates that it found an ATI
Radeon 9600 and my monitor.  That's about all the good it does.  The
drivers work fine in the version of XFree packaged with FC2.  I am
using the Mesa driver for the ATI Radeon 9600, since I only work with
2D graphics, and it works just fine.

The transition to FC3, however, seems to have broken support for my
video card.  I cannot provide any logs or otherwise because I can't
even see my screen with FC3 installed.

I realize that the ATI Radeon 9600XT is not fully supported except
through ATI's proprietary binaries.  This, however, does not excuse
the lack of fundamental support for a well-known and well-used piece
of hardware, especially when it works in prior releases.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from the install CDs
2. Select graphical installation
3. Make sure the hardware is the same, since that seems to be the crux
of the problem
4. Watch for the black screen of death
    

Actual Results:  Just as described above.  My screen either goes
entirely black or flickers at regular intervals.

Expected Results:  My video card should have been properly supported.
 This is basic functionality that every good OS ought to have.

Additional info:
Comment 1 Larry Weaver 2004-11-24 15:27:02 EST
I have experienced the same problem with the installation. Once FC3 is
up, I get failure to clear windows, window fragments left on
screen,etc. I have an Intel i810 on-board video card and a generic
monitor with:
       HorizSync    31.5 - 48.5
        VertRefresh  50.0 - 70.0
        Option      "dpms"
This same configuration runs FC3 Test1 just fine.
Comment 2 Mike A. Harris 2005-02-05 14:53:24 EST
"XFree86" does not exist in Fedora Core 2 or later.  Reassigning
to "xorg-x11" component.
Comment 3 Mike A. Harris 2005-02-05 15:28:43 EST
Thanks for your report.  Here is some feedback based on the
initial bug comments:

> Problem non-existent with FC2, which I am currently back to because
> FC3 breaks my machine.

This is kindof odd, because the Radeon 9600XT isn't officially
supported by the "radeon" driver in Fedora Core 2.  There is
experimental support patched into FC2 for some of the newer
Radeon models, but it was never very stable.  Were you using
the "vesa" driver in FC2 perhaps?

> I am using the Mesa driver for the ATI Radeon 9600, since I only
> work with 2D graphics, and it works just fine.

I think you're slightly confused about the drivers, as the Mesa
drivers are DRI drivers which provide OpenGL 3D acceleration.  They
are not used by the 2D pipeline.  Additionally, the Mesa drivers
do not support any Radeon hardware newer than Radeon 9200 (in any
XFree86 or X.Org X11 release).

You're either using the 2D-only "radeon" driver (most likely), or
the "vesa" driver.

> The transition to FC3, however, seems to have broken support for my
> video card.  I cannot provide any logs or otherwise because I can't
> even see my screen with FC3 installed.

X.Org X11 6.8.x shipped in FC3 is the first X.Org release to
officially support the Radeon 9600XT.  Previous releases of
X.Org X11 did not support this video hardware at all.  Red Hat
obtained some experimental patches for some of the newer hardware
from ATI directly, and applied them to FC2 xorg-x11-6.7.0 as
"unsupported experimental support" in hopes that it might work
for some users.  Overall, it did not work correctly for most
users, but it did work for some people, perhaps your system was
one of the lucky ones.

If the FC3 radeon driver does not work for you, then it is possible
that something changed in the driver at X.Org which may be causing
the problem you're experiencing.


> I realize that the ATI Radeon 9600XT is not fully supported except
> through ATI's proprietary binaries. 

That's actually backwards.  Radeon 9600XT is supported 2D-only,
using the open source "radeon" driver included with Fedora Core 3
and later.  While Red Hat does not provide nor support ATI's
proprietary drivers, users can download them for free from
ATI's website directly.  ATI does not provide end user technical
support for their proprietary drivers to my knowledge.


> This, however, does not excuse the lack of fundamental support
> for a well-known and well-used piece of hardware, especially
> when it works in prior releases.

I think there might be a bit of confusion about video driver
support, so I will try to clarify things a bit.

The open source video drivers included in Fedora Core and other Red
Hat OS products, are not produced by Red Hat directly.  They are
produced and provided by X.Org (http://www.x.org
http://xorg.freedesktop.org).  All of the video drivers are
developed by the X.Org community of developers, along with various
code contributions from the hardware vendors themselves.  Some of
the hardware vendors fund the development of the X.Org drivers via
3rd party graphics companies such as Tungsten Graphics.

OS distributions such as Fedora Core, Mandrake, Debian, etc. ship
the drivers as provided by X.Org, and any bugs that might be
found in the drivers are generally speaking, not OS distribution
specific.  The majority of bugs that are discovered by end users,
are bugs in the drivers as they were supplied by X.Org.

Users experiencing bugs with the X.Org video drivers, should file
a bug report in the official X.Org bug tracker in the "xorg"
component at http://bugs.freedesktop.org   By doing so, this ensures
that the driver maintainers, ATI (or other vendors), as well as
other X.Org developers are aware of the problem and can investigate
the issue for future X.Org releases and updates.

Once you have filed your bug report in the X.Org bug tracker,
please paste the URL here and Red Hat will track the issue in the
X.Org bugzilla, and review any fixes that become available for
consideration in future Fedora Core updates.

Comment 4 Mike A. Harris 2005-02-05 15:32:07 EST
In reply to Larry Weaver (lweaver@cruzio.com) comment #1:

The i810 driver problem you're experiencing with i810 hardware
in FC3, is a known issue that was fixed in an xorg-x11 update
after FC3 was released.  It is unrelated to the problem being
reported here.  Please update your FC3 system to all of the
latest updates and the issue should be resolved.
Comment 5 Mike A. Harris 2005-02-05 15:37:32 EST
One thing I forgot to mention in comment #3, is that X.Org 6.8.2
will be released soon by X.Org.  The new release is a bugfix release
that fixes numerous bugs throughout the server, drivers, client
libraries, etc.  We will be providing 6.8.2 as an official update
to xorg-x11 for Fedora Core 3 once it is released.

Please test xorg-x11-6.8.1.904 (6.8.2rc4) or later from fedora
development to see if this problem is resolved in the newer release,
before reporting the problem to X.Org.  If the problem persists
in the Fedora devel xorg-x11 build however, then follow through
with filing a bug report to X.Org bugzilla as suggested in
comment #3 above, and we will track the issue there, and
review fixes as they become available.

Thanks again.

Setting status to "NEEDINFO", awaiting Fedora devel xorg testing
results, and X.Org bug report URL.
Comment 6 Mike A. Harris 2005-04-15 10:31:00 EDT
We believe this problem was resolved in errata for FC3.  Please upgrade
to the latest errata release.

Note You need to log in before you can comment on or make changes to this bug.