Bug 139967 - USB Devices de-register on boot
USB Devices de-register on boot
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-11-18 17:41 EST by Matthew V. Weigl
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-02 20:53:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthew V. Weigl 2004-11-18 17:41:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Running uniprocessor does not resolve the issue.

Issue did not occur on install, nor on first boot. Occurred on first
boot after up2date of everything. Found some mention of udev on the
net, so I rolled back to udev-039-10.FC3.1, which did not resolv the
issue. Eventually found this message: 

I tried manual loading of modules and it worked. I update my
modprobe.conf and saw probeall does not appear to be valid anymore, so
I updated modprobe.conf as follows (originals are commented out):

alias usb-controller usb-modules
install usb-modules /sbin/modprobe ehci-hcd; /sbin/modprobe uhci-hcd
remove usb-modules /sbin/modprobe -r uhci-hcd; /sbin/modprobe -r ehci-hcd
#alias usb-controller ehci-hcd
#alias usb-controller1 uhci-hcd

That resolved the issue. Hardware is an Abit IC7-G.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot without above changes

Actual Results:  All USB is dergistered at boot

Expected Results:  USB should have stayed registered

Additional info:
Comment 1 Dave Jones 2005-07-15 14:30:48 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 Dave Jones 2005-10-02 20:53:11 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.