Bug 139994 - Kernel configuration tools inconsistent
Kernel configuration tools inconsistent
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Peter Martuccelli
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-19 02:16 EST by Rainer Koenig
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-05 15:04:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Koenig 2004-11-19 02:16:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040917 Firefox/0.9.3

Description of problem:
The use of Kernel configuration tools like "make menuconfig" or
"make xconfig" damage the .config file and that results in compilation
problems. 

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.EL

How reproducible:
Always

Steps to Reproduce:
1. Install kernel source package

2. Copy a working .config (e.g. from the /boot directory to .config )

3. To monitor the changes in .config apply the following line
# grep -v "^#" | grep -v "^$" | sort > config.before

4. Call one of the configuration tools e.g. `make xconfig` 

5. Don't change anything in the kernel config, just save it from
that tool.

6. Do the commandline from step 3 again, this time rename the output
file to something like "config.after"

7. Make a `diff config.before config.after`

Actual Results:  Depending on the config tool you used you will see
more or less differences:
- Some configuration settings were erased (e.g. settings with CRYPTO
in it when using `make xconfig`)
- Some configuration settings were changed from "m" to "y" (happens
mostly with `make menuconfig`).

Expected Results:  Since I just opened and saved the configuration I
expect the diff to not show any difference. The filter with the 2
greps and sort should ensure that comments and blank lines are
filtered out and that even a change in the sequence is corrected by
the sort. So semantically the kernel configuraton file should be
consistent.

Additional info:

This behaviour leads to strange errors during kernel compilation.
Especially since the modules where the error occurs are usually not
related to the configuration changes a user does. 

If you search bugzilla you will find bug reports 109636, 119781,
114659 (which already describes some of the changes in the .config
file), 104676 and 103067 which from my point of view are all caused by
the misbehaviour of the kernel configuration toolchain. 

In some cases the problems can be fixed by running a `make oldconfig`
after using the buggy tools, but its an ugly workaround especially
since usually you get asked for settings that you didn't touch and you
maybe have no idea what you should chose.

And since people trust in the consistency of the configuration tools
they are looking for bugs in the kernel modules that show the
compilation problems even if those modules are practically innocent. 
This results in a waste of precious time and can lead to new bug
reports here.
Comment 1 Peter Martuccelli 2006-01-05 15:04:43 EST
RHEL3 is entering maintenance mode.  This issue was reviewed and will not be
addressed in RHEL3.  

The proper build sequence to follow is: make mrproper, cp
configs/kernel-2.4.21-i686-smp.config .config, make oldconfig, make dep, make
bzImage, make modules, make modules_install

Closing this issue out as wontfix.

Note You need to log in before you can comment on or make changes to this bug.