Bug 140045 - gcc-java install via yum fails due to unmet dependancy
gcc-java install via yum fails due to unmet dependancy
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-19 09:30 EST by Aidan Delaney
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 09:42:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aidan Delaney 2004-11-19 09:30:15 EST
Description of problem:
Installation problem with gcc-java, failed dependancy

Version-Release number of selected component (if applicable):
[root@localhost tmp]# uname -a
Linux localhost.localdomain 2.6.9-1.667 #1 Tue Nov 2 14:41:25 EST 2004
i686 i686 i386 GNU/Linux

[root@localhost tmp]# yum --version
2.1.11

How reproducible:
yum install gcc-java

Steps to Reproduce:
1. Try to "yum install gcc-java"
2. Observe installation failure due to failed dependancy
  
Actual results:
[root@localhost tmp]# yum install gcc-java
Repository base already added, not adding again
Setting up Install Process
Setting up Repo:  base
repomd.xml                100% |=========================| 1.1 kB    00:00
Setting up Repo:  updates-released
repomd.xml                100% |=========================|  951 B    00:00
Reading repository metadata in from local files
base      : ################################################## 2622/2622
updates-re: ################################################## 210/210
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gcc-java.i386 0:3.4.2-6.fc3 set to be installed
--> Running transaction check
--> Processing Dependency: gcc= 3.4.2-6.fc3 for package: gcc-java
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package gcc.i386 0:3.4.2-6.fc3 set to be updated
--> Running transaction check
--> Processing Dependency: cpp= 3.4.2-6.fc3 for package: gcc
--> Processing Dependency: gcc= 3.4.3-2 for package: gcc-c++
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package cpp.i386 0:3.4.2-6.fc3 set to be updated
--> Running transaction check
--> Processing Dependency: gcc= 3.4.3-2 for package: gcc-c++
--> Finished Dependency Resolution
Error: missing dep: gcc for pkg gcc-c++


Expected results:
I'd expect all dependancies to be automagically fetched and installed.

Additional info:
Comment 1 Jakub Jelinek 2004-11-19 09:42:40 EST
You have most probably partially updated to rawhide at some point and now
don't include rawhide anymore or something.
All the dependencies are ok if you have gcc*, cpp* and lib{gcj,stdc++,gcc,f2c,gnat,objc}* either all 3.4.2* or all 3.4.3* (the latter
is only in rawhide).

Note You need to log in before you can comment on or make changes to this bug.