Bug 140053 - NFS Buggy Server Error upon reboot
NFS Buggy Server Error upon reboot
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: nfs-utils (Show other bugs)
2.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Layton
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-19 10:08 EST by Paul J Sidoti
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:21:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul J Sidoti 2004-11-19 10:08:15 EST
Description of problem:

Upon reboot error is generated:

NFS:  Buggy Server nlink ==0!
--nfs_fhget :iget failed

Can't see all files in filesystem:  Permission denied/ I/O error

Version-Release number of selected component (if applicable):


How reproducible:
Every Time

Steps to Reproduce:
1.cd to nfs_mounted drive
2.su - root
3.ls contents
      
Actual results:
ls: akx01.dbf: Permission denied
ls: amvx001.dbf: Permission denied
ls: asox01.dbf: Permission denied
ls: axx01.dbf: Permission denied
ls: bisx001.dbf: Permission denied
ls: bnex01.dbf: Permission denied
ls: crpx01.dbf: Permission denied
ls: csex01.dbf: Permission denied
ls: cssx01.dbf: Permission denied
ls: cuex01.dbf: Permission denied
ls: czx001.dbf: Permission denied
ls: eaaxd001.dbf: Permission denied
ls: engd01.dbf: Permission denied
ls: evmx001.dbf: Permission denied
ls: frmx001.dbf: Permission denied
ls: glx01.dbf: Permission denied
ls: gmpx001.dbf: Permission denied
ls: hrid01.dbf: Permission denied
ls: ibpx01.dbf: Permission denied
ls: icxx01.dbf: Permission denied
ls: igcd01.dbf: Permission denied
ls: igsd01.dbf: Permission denied
ls: ipdd01.dbf: Permission denied
ls: jad01.dbf: Permission denied
ls: jtsd01.dbf: Permission denied
ls: mfgd01.dbf: Permission denied
ls: oed01.dbf: Permission denied
ls: oked01.dbf: Permission denied
ls: okxd01.dbf: Permission denied
ls: osmdo1.dbf: Permission denied
ls: pjmd001.dbf: Permission denied
ls: poad01.dbf: Permission denied
ls: psbd01.dbf: Permission denied
ls: qad01.dbf: Permission denied
ls: rlad01.dbf: Permission denied
ls: stats01.dbf: Permission denied
ls: wipx01.dbf: Permission denied
ls: wshx01.dbf: Permission denied
ls: xnmx001.dbf: Permission denied
ls: xtrx001.dbf: Permission denied


Expected results:
akx01.dbf
amvx001.dbf
asox01.dbf
axx01.dbf
bisx001.dbf
bnex01.dbf
crpx01.dbf
csex01.dbf
cssx01.dbf
cuex01.dbf
czx001.dbf
eaaxd001.dbf
engd01.dbf
evmx001.dbf
frmx001.dbf
glx01.dbf


etc . . . etc. . . 

Additional info:

can't open database because it says file is in use.  It is not
Comment 1 Suzanne Hillman 2004-11-19 14:27:18 EST
In order for root to see an NFS mounted file system, it needs to have been
exported no_root_squash.

Did you do this?
Comment 2 Paul J Sidoti 2004-11-19 14:36:04 EST
Nope.  Never had the problem before.  the nfs drives are mounted via 
the /etc/fstab file.

nas-head:/u27    /u27                   nfs    defaults        1 2

How would I modify the file?
Like this?
nas-head:/u27    /u27                   nfs    no_root_sqash   1 2

Comment 3 Suzanne Hillman 2004-11-22 10:32:32 EST
That looks about right (not sure if you need to include defaults as
well or not), although you've spelled 'no_root_squash' incorrectly.
You're missing the 'u'.

Have you tried that?
Comment 4 Jeff Layton 2007-07-17 08:03:52 EDT
AS2.1 is now in maintenance mode. If a problem isn't catastrophic then it
probably won't be addressed.

That said, this error usually indicates a server-side problem. What sort of
server is this?

no_root_squash is also an export option, not a mount option. root will still be
able to see the NFS filesystem without that export option, it's just that uid=0
will be translated to an unprivileged user (usu nobody or nfsnobody).
Comment 5 RHEL Product and Program Management 2007-10-19 15:21:22 EDT
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.