Bug 140072 - satellite-sync dying -- too many open files
satellite-sync dying -- too many open files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
360
All Linux
low Severity low
: ---
: ---
Assigned To: Mihai Ibanescu
Max Spevack
:
Depends On:
Blocks: 151683
  Show dependency treegraph
 
Reported: 2004-11-19 11:36 EST by Max Spevack
Modified: 2007-07-31 11:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 12:08:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Spevack 2004-11-19 11:36:39 EST
satellite-sync is failing on a rhel2.1 box after downloading 996 out
of 1466 packages.  This is with the -58 ISO, and going through an HTTP
Proxy, in case that matters (though I don't think it does).

the output of sync:

SYNC ERROR: attempting to display as much information as possible:

(Check logs/email for potentially more detail)

[Errno 24] Too many open files

------------

and the contents of the email it sends:

ERROR: a general socket occurred:

Exception reported from test07.rhndev.redhat.com
Time: Fri Nov 19 11:04:52 2004
Exception type socket.error

Exception Handler Information
Traceback (innermost last):
  File "/usr/bin/satellite-sync", line 128, in main
    return satsync.Runner().main()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 154, in main
    ret = method()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 244, in
_step_rpms
    self._packages_report = self.syncer.download_rpms()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 867, in
download_rpms
    self._fetch_packages(channel, missing_fs_packages)
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1710, in
_fetch_packages
    stream = rpmServer.getRpmStream(channel, rpmManip.nvrea())
  File "/usr/share/rhn/satellite_tools/xmlWireSource.py", line 236, in
getRpmStream
  File "/usr/share/rhn/satellite_tools/xmlWireSource.py", line 212, in
_xmlrpc
  File "/usr/lib/python1.5/site-packages/rhn/_internal_xmlrpclib.py",
line 984, in __call__
  File "/usr/lib/python1.5/site-packages/rhn/rpclib.py", line 308, in
_request
  File "/usr/lib/python1.5/site-packages/rhn/transports.py", line 168,
in request
  File "/usr/lib/python1.5/site-packages/rhn/transports.py", line 693,
in send_http
  File "/usr/lib/python1.5/site-packages/rhn/connections.py", line
244, in connect
  File "/usr/lib/python1.5/site-packages/rhn/connections.py", line
136, in getresponse
  File "/usr/lib/python1.5/site-packages/rhn/_httplib.py", line 99, in
__init__
error: (24, 'Too many open files')


11:04:52 SYNC ERROR: attempting to display as much information as
possible:

Exception reported from test07.rhndev.redhat.com
Time: Fri Nov 19 11:04:52 2004
Exception type exceptions.OSError

Exception Handler Information
Traceback (innermost last):
  File "/usr/bin/satellite-sync", line 157, in ?
    sys.exit(abs(main() or 0))
  File "/usr/bin/satellite-sync", line 136, in main
    systemExit_exception(1, msg, e)
  File "/usr/bin/satellite-sync", line 115, in systemExit_exception
    satsync.sendMail(forceEmail=1)
  File "/usr/share/rhn/satellite_tools/satsync.py", line 271, in sendMail
    rhnMail.send(headers, body, sender='rhn-satellite')
  File "/usr/share/rhn/common/rhnMail.py", line 39, in send
    (read, write) = os.pipe()
OSError: [Errno 24] Too many open files
Comment 1 Mihai Ibanescu 2004-11-23 11:25:48 EST
I don't think this is easy to reproduce, is it?
Do you still have the satellite around? I could have a look in the log
files...
Comment 2 Mihai Ibanescu 2004-12-03 23:00:48 EST
I will leave this bug open in case we can reproduce it more reliably.
Comment 3 Max Spevack 2004-12-05 21:57:13 EST
Has not reproduced yet.  Recommend closing as NOTABUG, as it has been
over 3 weeks.
Comment 4 Max Spevack 2004-12-06 16:05:28 EST
Cannot reproduce.  Will reopen if needed.
Comment 5 Mark Hudson 2005-01-24 10:38:57 EST
I am also getting this problem, trying to sync the rhel-i386-as-3 channel.

Comment 6 Mark Hudson 2005-01-24 10:41:02 EST
Here's the email that the satellite sent...

15:23:24
ERROR: a general socket occurred:

Exception reported from coyote.open.ac.uk
Time: Mon Jan 24 15:23:24 2005
Exception type socket.error

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/satellite-sync", line 134, in main
    return satsync.Runner().main()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 154, in main
    ret = method()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 245, in
_step_rpms
    self._packages_report = self.syncer.download_rpms()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 869, in
download_rpms
    self._fetch_packages(channel, missing_fs_packages)
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1725, in
_fetch_packages
    package_id, nvrea, sources)
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1803, in
_get_package_stream
    stream = rpmServer.getRpmStream(channel, nvrea)
  File "/usr/share/rhn/satellite_tools/xmlWireSource.py", line 236, in
getRpmStream
  File "/usr/share/rhn/satellite_tools/xmlWireSource.py", line 212, in
_xmlrpc
  File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 308, in
_request
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 168,
in request
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 693,
in send_http
  File "/usr/lib/python2.2/site-packages/rhn/connections.py", line
244, in connect
  File "/usr/lib/python2.2/site-packages/rhn/connections.py", line
136, in getresponse
  File "/usr/lib/python2.2/httplib.py", line 213, in __init__
error: (24, 'Too many open files')


15:23:24 SYNC ERROR: attempting to display as much information as
possible:

Exception reported from coyote.open.ac.uk
Time: Mon Jan 24 15:23:24 2005
Exception type exceptions.OSError

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/satellite-sync", line 163, in ?
    sys.exit(abs(main() or 0))
  File "/usr/bin/satellite-sync", line 142, in main
    systemExit_exception(1, msg, e)
  File "/usr/bin/satellite-sync", line 121, in systemExit_exception
    satsync.sendMail(forceEmail=1)
  File "/usr/share/rhn/satellite_tools/satsync.py", line 272, in sendMail
    rhnMail.send(headers, body, sender='rhn-satellite')
  File "/usr/share/rhn/common/rhnMail.py", line 39, in send
    (read, write) = os.pipe()
OSError: [Errno 24] Too many open files




And this is cut/pasted directly from the shell window...

...
15:23:17     994/1622 Fetch successful: gd-progs-1.8.4-12.3.1.i386.rpm
(101277 bytes)
15:23:24     995/1622 Fetch successful: rh-postgresql-7.3.8-2.i386.rpm
(1670116 bytes)
+++ sending log as an email +++
+++ sending log as an email +++
SYNC ERROR: attempting to display as much information as possible:

(Check logs/email for potentially more detail)

[Errno 24] Too many open files


(PS. I am a customer...)
Comment 7 Max Spevack 2005-01-24 10:45:55 EST
Reopening, and assigning to misa, since a customer has hit this in the
field.
Comment 8 Stuart Campbell 2005-03-18 04:02:55 EST
Just to say that I also am seeing this problem.
I am running RHN Satellite 3.6 on a RHEL 3 machine.
Comment 9 Mihai Ibanescu 2005-05-17 12:08:27 EDT
This should be fixed in the latest version of 3.6 code.

Note You need to log in before you can comment on or make changes to this bug.