Bug 140077 - Problem with french installation
Summary: Problem with french installation
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: man-pages-fr (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Eido Inoue
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-19 16:57 UTC by Pierre Fumery
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 20:22:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pierre Fumery 2004-11-19 16:57:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040514

Description of problem:
When choosing french installation, we got weird messages, even english
ones like :
      echo $LANG
      fr_FR.UTF-8
      man top
      TOP(1)                        Linux User�s Manual              
        TOP(1)
      ...
      man ls
      LS(1L)                   Manuel de l�utilisateur Linux         
        LS(1L)
      ...


The LANG variable is set by default to fr_FR.UTF-8
It doesn't look right ...

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.648

How reproducible:
Always

Steps to Reproduce:
1. To install RHEL4-beta2 on any platforms
2. To choose french installation
3.
    

Actual Results:  Weird messages (see description)

Expected Results:  French (or at least correct english) messages were
expected.

Additional info:

If you set LANG to a "correct" value : export LANG=fr_FR
it will work for some commands like
      man ls
      LS(1L)                   Manuel de l'utilisateur Linux         
        LS(1L)

      NOM
             ls, dir, vdir - Afficher le contenu d'un r�pertoire.



but still not for other ones like :
      man top
      TOP(1)                        Linux User�<80><99>s Manual

Comment 1 Pierre Fumery 2004-11-19 17:01:33 UTC
On other plateforms, results are a little different.

On x86, when setting export LANG=fr_FR, you'll get :

      man top
      TOP(1)                        Linux Userâ<80><99>s Manual
      man ls
      LS(1L)                   Manuel de l'utilisateur Linux         
        LS(1L)

Even when you choose english version (export LANG=en_EN), you'll get
mis-formatted messages :

      man top
      TOP(1)                        Linux Userâ<80><99>s Manual
      man ls
      LS(1L)                   Manuel de l'utilisateur Linux         
        LS(1L)






Comment 2 Eido Inoue 2004-11-22 08:15:45 UTC
I'm not seeing these problems on the latest RHEL4/FC3 with updates.
Can't reproduce. My French and English pages are displaying fine.

Confirm that your groff, less, man, gnome-terminal, vte are up2date
and gnome-terminal is set in the right character encoding.

Comment 3 JoAnne K. Halligan 2004-11-30 23:51:54 UTC
Adrian, 

As the partner only has the last RHEL4 B2 provided by engineering, can
you please confirm that you used the version they note above or put in
here specifically what version you saw it work on and how I can get
that to the partner to try? 

We need to do that before closing the item, otherwise is hasn't solved
the problem from the partner perspective. 

I've also asked the partner to please confirm the items you noted above.

Thanks, JoAnne


Comment 4 Pierre Fumery 2004-12-01 09:23:21 UTC
Adrian,
We just select "french installation" and we discovered that the LANG
variable was set to fr_FR.UTF-8 and we got weird displays.

After that, we tried to find out workarounds without success.

It may be due to beta versions and it will work fine with newer
deliveries ? You might be aware of such poblems and they may have
already been fixed. Please let us know and we'll test next available
RHEL3 beta or release candidate versions.


Comment 5 Eido Inoue 2004-12-10 20:22:29 UTC
comment 1: setting LANG to non-UTF-8 settings (ex. en_US or fr_FR vs
en_US.UTF-8 and fr_FR.UTF-8) is not supported by groff/nroff, which is
used by man.

comment 3: re-confirmed with stock beta 2, and did not encounter
problems. French displayed correctly. Partner should also have access
to pre1.


Note You need to log in before you can comment on or make changes to this bug.