Bug 140079 - php-gd can't find fonts
php-gd can't find fonts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-19 12:11 EST by Joe Orton
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-06 15:51:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
php-gd test script (1.10 KB, text/plain)
2004-11-19 12:12 EST, Joe Orton
no flags Details

  None (edit)
Description Joe Orton 2004-11-19 12:11:37 EST
I'll attach my stock php-gd test script, it's broken with SELinux
because it can't find fonts:

audit(1100884417.855:0): avc:  denied  { search } for  pid=5177
exe=/usr/sbin/httpd name=fonts dev=md0 ino=1799276
scontext=root:system_r:httpd_t tcontext=system_u:object_r:fonts_t
tclass=dir

selinux-policy-targeted-1.19.1-9
Comment 1 Joe Orton 2004-11-19 12:12:57 EST
Created attachment 107065 [details]
php-gd test script

install as /var/www/html/img.php and load http://localhost/img.php, expect to
see pretty text
Comment 2 Daniel Walsh 2004-11-19 15:23:44 EST
Fixed in selinux-policy-targeted-1.19.3-1 and
selinux-policy-targeted-1.17.30-2.32
Comment 3 Joe Orton 2004-12-06 15:51:05 EST
Confirmed fixed with selinux-policy-targeted-1.17.30-2.35, thanks.

Note You need to log in before you can comment on or make changes to this bug.