Bug 140122 - evolution locks up when clicking on pasted message block in compose window
evolution locks up when clicking on pasted message block in compose window
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gtkhtml3 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-19 16:17 EST by Ray Strode [halfline]
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 19:28:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Strode [halfline] 2004-11-19 16:17:29 EST
I was pasting an email into the evolution compose window and I clicked
inside the pasted message block when evolution locked up.
relevant package versions:

evolution-2.0.2-1
gtkhtml3-3.3.2-3

backtrace:
 bt
#0  0x02ca917d in html_object_prev_not_slave (object=0xacc3100) at
htmlobject.c:1203
#1  0x02ca9add in move_object_cursor (obj=0xacc3180, offset=0xb74d624,
forward=0, next_fn=0x2ca9174 <html_object_prev_not_slave>,
    down_fn=0x2ca96af <html_object_tail_not_slave>) at htmlobject.c:1489
#2  0x02ca9c84 in html_object_prev_cursor (self=0xacc3100,
offset=0x2cdba40) at htmlobject.c:1574
#3  0x02c7e647 in backward (cursor=0xb74d620) at htmlcursor.c:266
#4  0x02c86846 in delete_object (e=0xad34710, ret_object=0x0,
ret_len=0x0, dir=HTML_UNDO_UNDO, add_undo=1) at
htmlengine-edit-cut-and-paste.c:583
#5  0x02c87a4a in delete_upto (e=0xad34710, start=0xfef03ed4,
end=0xacc3100, object=0xacc3100, offset=181154048) at
htmlengine-edit-cut-and-paste.c:1698
#6  0x02c87bef in html_engine_delete (e=0xad34710) at
htmlengine-edit-cut-and-paste.c:1747
#7  0x02c88686 in html_engine_delete_n (e=0xad34710, len=0, forward=0)
at htmlengine-edit-cut-and-paste.c:1429
#8  0x02c71637 in command (html=0xb1be948,
com_type=GTK_HTML_COMMAND_DELETE_BACK_OR_INDENT_DEC) at gtkhtml.c:4479
#9  0x00d06113 in IA__g_cclosure_marshal_VOID__ENUM
(closure=0x9f3a458, return_value=0x0, n_param_values=2,
param_values=0xb8678a8, invocation_hint=0xfef04178,
    marshal_data=0x2c703c7) at gmarshal.c:356
#10 0x00ceecda in g_type_class_meta_marshal (closure=0x9f3a458,
return_value=0x0, n_param_values=2, param_values=0xb8678a8,
invocation_hint=0xfef04178,
    marshal_data=0x200) at gclosure.c:514
#11 0x00ceea84 in IA__g_closure_invoke (closure=0x9f3a458,
return_value=0x0, n_param_values=2, param_values=0xb8678a8,
invocation_hint=0xfef04178) at gclosure.c:437
#12 0x00d051bd in signal_emit_unlocked_R (node=0x9f748c0, detail=0,
instance=0xb1be948, emission_return=0x0,
instance_and_params=0xb8678a8) at gsignal.c:2480
#13 0x00d03678 in IA__g_signal_emitv (instance_and_params=0xb8678a8,
signal_id=305, detail=0, return_value=0x0) at gsignal.c:2113
#14 0x0022abc1 in gtk_binding_entry_activate (entry=0x9f75f38,
object=0xb1be948) at gtkbindings.c:526
#15 0x0022b946 in binding_match_activate (pspec_list=0xb85e2c0,
object=0xb1be948, path_length=7, path=0x9e60ed8 "GtkHTML",
path_reversed=0xb8616a8 "LMTHktG")
    at gtkbindings.c:928
#16 0x0022bc75 in gtk_bindings_activate_list (object=0xb1be948,
entries=0xb85e248, is_release=0) at gtkbindings.c:1064
#17 0x0022bfe4 in IA__gtk_bindings_activate_event (object=0xb1be948,
event=0xb762884) at gtkbindings.c:1139
#18 0x0044bc46 in gtk_widget_real_key_press_event (widget=0xb1be948,
event=0xb762884) at gtkwidget.c:3331
#19 0x02c66d92 in key_press_event (widget=0xb1be948, event=0xb762884)
at gtkhtml.c:884
#20 0x0032142c in _gtk_marshal_BOOLEAN__BOXED (closure=0x9e04cf8,
return_value=0xfef04600, n_param_values=2, param_values=0xfef047d0,
invocation_hint=0xfef04638,
    marshal_data=0x2c66bb5) at gtkmarshalers.c:83
#21 0x00ceecda in g_type_class_meta_marshal (closure=0x9e04cf8,
return_value=0xfef04600, n_param_values=2, param_values=0xfef047d0,
invocation_hint=0xfef04638,
    marshal_data=0xcc) at gclosure.c:514
#22 0x00ceea84 in IA__g_closure_invoke (closure=0x9e04cf8,
return_value=0xfef04600, n_param_values=2, param_values=0xfef047d0,
invocation_hint=0xfef04638)
    at gclosure.c:437
#23 0x00d051bd in signal_emit_unlocked_R (node=0x9e04d48, detail=0,
instance=0xb1be948, emission_return=0xfef04750,
instance_and_params=0xfef047d0) at gsignal.c:2480
#24 0x00d04194 in IA__g_signal_emit_valist (instance=0xb1be948,
signal_id=51, detail=0, var_args=0xfef04960 "\220I��\200��\t\001") at
gsignal.c:2211
#25 0x00d0444d in IA__g_signal_emit (instance=0xb1be948, signal_id=51,
detail=0) at gsignal.c:2245
#26 0x0044c28a in gtk_widget_event_internal (widget=0xb1be948,
event=0xb762884) at gtkwidget.c:3587
#27 0x0044bde4 in IA__gtk_widget_event (widget=0xb1be948,
event=0xb762884) at gtkwidget.c:3393
#28 0x0045da95 in IA__gtk_window_propagate_key_event
(window=0xb80fa70, event=0xb762884) at gtkwindow.c:4549
#29 0x0045db58 in gtk_window_key_press_event (widget=0xb80fa70,
event=0xb762884) at gtkwindow.c:4579
#30 0x02801636 in bonobo_window_get_accel_group () from
/usr/lib/libbonoboui-2.so.0
#31 0x0032142c in _gtk_marshal_BOOLEAN__BOXED (closure=0x9e04cf8,
return_value=0xfef04c40, n_param_values=2, param_values=0xfef04e10,
invocation_hint=0xfef04c78,
    marshal_data=0x28015f8) at gtkmarshalers.c:83
#32 0x00ceecda in g_type_class_meta_marshal (closure=0x9e04cf8,
return_value=0xfef04c40, n_param_values=2, param_values=0xfef04e10,
invocation_hint=0xfef04c78,
    marshal_data=0xcc) at gclosure.c:514
#33 0x00ceea84 in IA__g_closure_invoke (closure=0x9e04cf8,
return_value=0xfef04c40, n_param_values=2, param_values=0xfef04e10,
invocation_hint=0xfef04c78)
    at gclosure.c:437
#34 0x00d051bd in signal_emit_unlocked_R (node=0x9e04d48, detail=0,
instance=0xb80fa70, emission_return=0xfef04d90,
instance_and_params=0xfef04e10) at gsignal.c:2480
#35 0x00d04194 in IA__g_signal_emit_valist (instance=0xb80fa70,
signal_id=51, detail=0, var_args=0xfef04fa0 "�O��\200��\t\001") at
gsignal.c:2211
#36 0x00d0444d in IA__g_signal_emit (instance=0xb80fa70, signal_id=51,
detail=0) at gsignal.c:2245
#37 0x0044c28a in gtk_widget_event_internal (widget=0xb80fa70,
event=0xb762884) at gtkwidget.c:3587
#38 0x0044bde4 in IA__gtk_widget_event (widget=0xb80fa70,
event=0xb762884) at gtkwidget.c:3393
#39 0x0031f7ab in IA__gtk_propagate_event (widget=0xb80fa70,
event=0xb762884) at gtkmain.c:2068
#40 0x0031e24f in IA__gtk_main_do_event (event=0xb762884) at
gtkmain.c:1332
#41 0x001802f3 in gdk_event_dispatch (source=0x9d7b620, callback=0,
user_data=0x0) at gdkevents-x11.c:2207
#42 0x00c19c42 in g_main_dispatch (context=0x9d7b668) at gmain.c:1943
#43 0x00c1b03d in IA__g_main_context_dispatch (context=0x9d7b668) at
gmain.c:2493
#44 0x00c1b55a in g_main_context_iterate (context=0x9d7b668, block=1,
dispatch=1, self=0x9d5c398) at gmain.c:2574
#45 0x00c1bd15 in IA__g_main_loop_run (loop=0x9e013f0) at gmain.c:2778
#46 0x02594dd5 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#47 0x08063af9 in main (argc=47036992, argv=0xfef055a4) at main.c:585
Comment 1 Ray Strode [halfline] 2004-11-19 16:19:59 EST
Also, I may have pressed backspace or delete after clicking in the box
before it locked up.  I'm not sure.
Comment 2 Dave Malcolm 2004-11-19 16:51:56 EST
From my attempts to debug this, it looked like it was stuck in an
infinite while loop in the gtkhtml code (possibly due to the NULL self
ptr?)
Comment 3 Dave Malcolm 2005-08-18 00:21:37 EDT
(see also bug #144375; possible duplicate)
Comment 5 Matthew Barnes 2007-01-01 07:55:33 EST
Is this problem still present in Fedora Core 6 or later?
Comment 6 Ray Strode [halfline] 2007-01-03 19:28:11 EST
Not sure, because i'm not exactly sure how I triggered it.  I certainly don't
hit it frequently. We can close it.

Note You need to log in before you can comment on or make changes to this bug.