Bug 140156 - Keyboard does not work in X after up2date to new kernel (2.6.9-1.3_FC2)
Summary: Keyboard does not work in X after up2date to new kernel (2.6.9-1.3_FC2)
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-20 10:42 UTC by Stanislav Traykov
Modified: 2015-01-04 22:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-12 12:34:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stanislav Traykov 2004-11-20 10:42:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
It had been a while, so I ran up2date which upgraded my (single
processor) kernel from 2.6.8-1.521 to 2.6.9-1.3_FC2. When I chose the
new kernel at the next boot, the keyboard was not working, I couldn't
log in (X mode).

I rebooted (using the mouse), chose the new kernel again, pushed some
keys during startup: the keyboard was working up to the console login
prompt (which appears for a moment at startup). When X started, I
couldn't log in again (nor Ctrl-Alt-1 to console).

When choosing the old kernel (2.6.8-1.521), the keyboard works under X.

System:
Sony Vaio Notebook (GRX316G, corresponds to GRX fivehundred-something
in the US)
Keyboard, Touchpad: PS/2

Version-Release number of selected component:
kernel-2.6.9-1.3_FC2

How reproducible:
Always

Steps to Reproduce:
1. Turn computer on
2. Wait until X login screen appears
3. Try to use the keyboard
    

Actual Results:  Keyboard dead. Can't log in, can't Ctrl-Alt switch to
console.

Additional info:
Assigning HIGH as there is no workaround except using an old kernel.

Comment 1 Gustavo Maciel Dias Vieira 2004-11-20 11:03:26 UTC
I'm experiencing the exact same behaviour on a Dell Inspiron 1150.
Module versions:
kernel-2.6.9-1.3_FC2
xorg-x11-6.7.0-10


Comment 2 Miles Sabin 2004-11-20 22:52:15 UTC
Same here too ... Sony Vaio Z1XSP.


Comment 3 Miles Sabin 2004-12-04 20:58:43 UTC
Same (lack of ;-) behaviour with kernel-2.6.9-1.6_FC2.

Is there any other information I can provide which would help to
resolve this?

Comment 4 Miles Sabin 2004-12-11 19:10:06 UTC
Turns out that for me this was a misconfigured xorg.conf. Under 2.6.8
my touchpad was bound to /dev/input/event0 which under 2.6.9 was
mapped to the keyboard. See,

  http://makeashorterlink.com/?A2B83500A


Comment 5 Dave Jones 2004-12-12 00:39:45 UTC
Stanislav, are you ok with closing this ?


Comment 6 Stanislav Traykov 2004-12-12 12:34:12 UTC
Yes. Let's blame the kernel :-)


Note You need to log in before you can comment on or make changes to this bug.