Bug 140194 - Installer and Rescue CD crashed with kernel panic
Installer and Rescue CD crashed with kernel panic
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-20 15:47 EST by Martin Bergs
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 22:14:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Bergs 2004-11-20 15:47:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5)
Gecko/20041108 Firefox/1.0

Description of problem:
I tried to install Fedora Core 3 but the installation always crashed
with following error:
Ramdisk: Compressed image found at block 0
crc error
VFS: Cannot open root device "<null>" or unknown-block (8,3)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: unable to mount root fs on
unknown-block (8,3)

With the rescue disk I got the same error.

I checked md5sum and used the same media in other machine for
installation successfully. I also tested the cd-rom drive and media in
other machine successfully.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot from disk 1 or rescue cd
2.
3.
    

Actual Results:  error:
Ramdisk: Compressed image found at block 0
crc error
VFS: Cannot open root device "<null>" or unknown-block (8,3)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: unable to mount root fs on
unknown-block (8,3)

Additional info:

My computer is a Hewlett-Packard Vectra VL 420 MT.
Pentium IV 1,6 GHz, 640 MB RAM, Seagate Barracuda 40 GB HDD
Comment 1 Jeremy Katz 2004-11-22 11:10:01 EST
Checking on another machine is unfortunately not as good of a check as
one might like.  Different CD drives have different tolerances,
especially for burned media.  Can you try burning disc1 at a slower
speed and see if that helps?
Comment 2 Martin Bergs 2004-11-24 12:42:18 EST
I don't believe it's a problem the burned media because I used the
media successful in the build-in HP CD drive (Liteon 48s) in another
computer. But with the same build-in HP CD drive in my Vectra VL 420
MT it doesn't work.

Nevertheless I burned a new media (now only quad speed) but I got the
same error message.
Maybe it depends from the Vectra HW but on the other hand a colleague
used my media successful to install FC3 on his Hewlett-Packard Vectra
VL 420 MT.
Comment 3 Joe Wood 2004-11-27 07:20:47 EST
My DVD (from ChyGwyn ltd) passes mediacheck, installs (with a cope of
minor problems) and loads rescue mode.

BUT both with installation and rescue mode the kernel panics cannot
sync VFS on (8,3).

Additionally on installation mode (I let this running over night)
after the installation was complete? (see below) everything appeared
to be OK, but the mouse suddenly frooze and I could not get any life
out of X, even ctrl-alt-bs.

I say "completed?" because on restarting my PC (dual boot
windows/linux) grub came to life entered stage 1.5? and said
(approx)grub stage2 loading ............
and died, only wy out was system reset button. This was repeatable.

Rerunning grub-install from rescue mode solved problem.
Comment 4 Steve Campbell 2004-12-06 06:49:56 EST
I get the same anaconda kernel panic trying to install from the
boot.iso or disk1 using a 52speed cdrom. It makes no difference
whether the media is burnt onto a CD-R or CD-RW
Comment 5 Martin Bergs 2004-12-07 04:06:07 EST
I think I found the problem.
The kernel panic while booting from CD might relate to the memory. I
have 2 256 MB modules. One is the built-in module from HP and the
other module I added is from Samsung (M366S3253DTS-L7A/C7A).
After I removed the Samsung memory module I could successfully install
fc3 from CD. When I assemble the Samsung module after installation I
got the kernel panic again.

The Samsung module is within the specifications from HP
"System Memory Support
• Directly supports one SDR SDRAM channel, 64 bits wide (72 bits with ECC)
• 133 MHz SDRAM devices
• 64 Mb, 128 Mb, 256 Mb and 512 Mb technologies for x8 and x16 devices"

With FC2 and also with Windows 2000 there are no problems when the
Samsung module is built-in.
Nevertheless I'm happy now that my FC3 installation was successful.
Comment 6 Steve Campbell 2004-12-07 11:13:53 EST
Brilliant - this was the cause of my kernel panic as well. In my case
a 256MB PC100 IRL DEM DP100-064322E module. Removing it resolved the
problem.

However, I cannot do without the module so am reverting to my
successful FC2 installation. Could this be resolved for FC4?
Comment 7 Daragh Fitzpatrick 2005-01-09 02:51:16 EST
Same happens for me - cannot confirm or deny the dependence on memory, since I
cannot remove the memory board - it's the only one in the system! 

I can say, however, that MemTest86 has concluded no problems with memory. 

The exact error I am seeing is:
"
Ramdisk: Compressed image found at block 0
crc error
VFS: Cannot open root device "<null>" or unknown-block (8,3)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block (8,3)
"
Comment 8 Daragh Fitzpatrick 2005-01-09 20:07:21 EST
SOLUTION: (for Windows users)

Nero Burning ROM does not properly burn FC3-i386-disc1.iso - I do not know why,
but it is the first time I have had issues with Nero. (Could it be because the
image ends mid-sector?)

I had success with ISO Recorder (free download from
http://isorecorder.alexfeinman.com), and also believe Alcohol 120% will work.

Cheers!

Daragh
Comment 9 Daragh Fitzpatrick 2005-01-09 20:28:11 EST
Oh - credit where it's due: 
http://www.linuxforums.org/forum/post-153922.html

Note You need to log in before you can comment on or make changes to this bug.