Bug 140214 - xbiff and other programs have been erroneously removed from xorg-x11-tools package
xbiff and other programs have been erroneously removed from xorg-x11-tools pa...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 173893 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 00:10 EST by Bryan Ischo
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-11 17:47:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Ischo 2004-11-21 00:10:16 EST
Description of problem:

The xbiff, xeyes, xditview, and xmessage programs have been
erroneously removed from the xorg-x11-tools package.  The comment in
the xorg-x11.spec file for this read:

* Sun Aug 22 2004 Mike A. Harris <mharris@redhat.com> 6.7.99.902-6
- Remove a bunch of legacy Xaw/Xt applications which really should not
be part of X11 sources (xbiff,xditview,xeyes,xmessage)

These programs should NOT have been removed from the xorg-x11-tools
package unless they were to be added to another package.  This removal
of these programs has completely eliminated them from the system,
which is wrong.  Maybe not many people use these programs, but I do,
and I see no reason for them to have been removed.

Version-Release number of selected component (if applicable):


How reproducible:

Install xorg-x11-tools, note that xbiff, xeyes, etc are missing from
the install even though the Description of the xorg-x11-tools package
partially reads:

"Various tools for X, including listres, xbiff, xeyes, xcalc, and
xload among others."


Steps to Reproduce:
1. Install xorg-x11-tools
2.
3.
  
Actual results:

No xbiff program installed.


Expected results:

xbiff program installed.

Additional info:

All that needs to happen is that the commenting out of some lines of
the xorg-x11.spec file (search for "xbiff" or "xeyes" to see what I
mean) needs to be undone, and the commands to remove these files from
the build before packaging needs to be removed.
Comment 1 Colin Charles 2004-12-30 01:17:38 EST
mharris: once Extras is sorted, is there interest to move xbiff/xeyes into an
Extras package from you? Or maybe a 3rd party maintainer? Thanks
Comment 2 Nathan Wallwork 2004-12-30 09:17:13 EST
Yes, certainly.  

I'd like to be able to get xbiff as part of a package.  As far as I know, there
isn't another program available in Fedora that serves the same function.  (watch
a file for changes, notify the user via an X program).

If such a program is already available then it would make sense to mention it in
the release notes near the word xbiff.
Comment 3 John Bass 2005-01-17 20:59:34 EST
I normally run 3-5 xbiffs for various email boxes on my systems.
It's a real pain to have to activate a shell to check mail on each of
them now
Comment 4 Mike A. Harris 2005-02-11 17:47:35 EST
Use the gnome panel applet for checking multiple mailboxes.
There are several calculator applications in the distribution
which can be used in place of xcalc.  Other apps noted above
have similar replacements in the distribution as well.

In the future, when X.Org X11 is modularized for X11R7, some of
these applications will either be removed from X.Org upstream
completely, or will be maintained as separate software outside
of X.Org major release, which is really where they belong all
along, as they don't really have much to do with the operation
of the X Window System itself.

The Fedora Project gladly welcomes any volunteers in the community
who would like to maintain rpms of xeyes/xbiff, etc. in Fedora
Extras in the future.

There are no plans of adding these removed applications back to
the Fedora Core however.

Setting status to "WONTFIX".
Comment 5 Mike A. Harris 2005-02-11 17:52:39 EST
Additionally..  there is a gnome panel applet to replace xeyes
I just discovered.  For those who use xeyes to locate their mouse
pointer, they can use the gnome panel applet, or they can use
the GNOME accessiblity features to increase the size of the mouse
pointer.  There is a feature that can highlight the mouse pointer
by pressing CTRL or something as well.   Hope this helps.
Comment 6 Bryan Ischo 2005-02-11 18:23:19 EST
As a final comment, I find it disappointing that no good reason was
ever given for removing these programs, other that you just don't like
them to be in there, despite the fact that they've been in the base X
distribution for what, 20 years now?  And that the few people who
really do want these programs have been ignored, despite the only
thing needing to be done to fix this problem is to remove a few
characters from the SPEC file.  It just seems like such an *easy*
problem to solve - simply put them back until there is a real plan for
moving them elsewhere.  After all, the X distribution includes these
programs, why does RedHat see the need to decide that something that
is included in the X distribution should not be included with their
packaging of the X distribution?

I will investigate making my own RPM for these programs.  I don't know
much about RPM, and I'm worried that it will be difficult to do since
these programs are a part of the X distribution's build process and
source code and making a completely separate RPM for them might be
difficult.
Comment 7 Mark Frazer 2005-02-21 10:36:36 EST
I've got to say removing a basic (& tiny) program like xbiff that
people have been using for years quite sucks.

One more push away from redhat for me.  At least our servers run
debian so I can run xbiff remotely.
Comment 8 Manuel Carro 2005-04-17 18:56:07 EDT
I too am disappointed by the removal without what appears to be a real need. 
The statement that there are "other replacements" can very well be taken to an
exterme by replacing Linux by another operating system.  Not that I am going to
do it, but this is a really weak reason.  Removing xbiff from the core X because
it does not belong to the "X Window System" itself suggests removing many other
applications as well.


Besides, the replacements suggested by so far just do *not* do what xbiff did:
monitor _file changes_ (any file!) in a standalone application.  I do not see
any way to do exactly this with the Gnome applet.  Besides, I do not use neither
Gnome nor KDE any longer.
Comment 9 Adam Jackson 2006-02-11 23:17:09 EST
*** Bug 173893 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.