Bug 140226 - i18n problem within grade scripts
i18n problem within grade scripts
Status: CLOSED NOTABUG
Product: Red Hat Academy
Classification: Retired
Component: RHA130 Curriculum (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bowe Strickland
Bowe Strickland
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 07:02 EST by Tomasz Chilinski
Modified: 2007-04-18 13:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-02 09:42:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Chilinski 2004-11-21 07:02:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.4.3)
Gecko/20040924

Description of problem:
Grade scripts should set manually LANG environment variable for
execution time. We could avoid many mistakes made by scripts thanks to
that!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
as above.
    

Additional info:
Comment 1 Bowe Strickland 2005-01-04 13:02:57 EST
i dont' think it's this simple.  i considered it, but what
if LANG is set to something else by student?  the goal of the
script is to reproduce the student's environment... 

i'd love to hear more arguments either way. --bowe
Comment 2 Tomasz Chilinski 2005-01-04 13:21:34 EST
LANG value is not important if you set LANG to en_US for script
runtime inside script. Student can set his favourite LANG values, but
scripts should ignore them the way which I have described. Isn't it
clear? ;-)
Comment 3 Tomasz Chilinski 2005-01-04 13:22:27 EST
Another method: you can prepare scripts for i18n ;-)
Comment 4 Bowe Strickland 2005-01-04 14:29:30 EST
sample scenerio....

lab asks student to sort /usr/share/dict/words > /tmp/t

student does so, with LANG=C (possibly w/o student's knowledge)

grading script then reperforms task into /tmp/tt, with LANG=en_US
and diffs /tmp/tt /tmp/t to see if studnet "did it right".  because
colation order is different, script grades the student wrong, where
if script had used same environemnt as student, it would have graded
it right.

this would seem to me to be bad... am i missing something here?

as for preparing for i18n... are you referring to gettext-izing?
as we stabalize, i'm definately interested in doing this...
Comment 5 Tomasz Chilinski 2005-01-04 14:57:37 EST
Yes you are right. I thought about gettext-zing and why not to do that
with you.
Maybe curriculum in polish too, somewhen in the future? ;-)

Note You need to log in before you can comment on or make changes to this bug.