Bug 140234 - Chipset Intel 915G (mb D915GEV) network and audio controller not recognised
Chipset Intel 915G (mb D915GEV) network and audio controller not recognised
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 10:21 EST by Giuseppe Giannuzzi
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 10:57:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (19.16 KB, text/plain)
2004-11-21 10:23 EST, Giuseppe Giannuzzi
no flags Details

  None (edit)
Description Giuseppe Giannuzzi 2004-11-21 10:21:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I installed FC3 on a system with mb Intel D915GEV (DDR 533 dual
channel, PCI Express on board graphic) and SATA hd (same behaviour for
FC2).

Although I advised that many devices are not recognised (see attached
lspci), the main system functionalities run (I can work) except for
NETWORK and AUDIO.

Network: Marvel Yukon 88E8050 PCI Express Gigabit Ethernet Controller
Not recognised

Audio: Intel High Definition Audio subsystem using the Realtek ALC860
audio codec.
Not recognised.
After boot the following sound server informational message appears:
"Error while initializing the sound driver
device /dev/dsp can't be opened (no such file or directory)
The sound server will continue using the null output device."

10x for any info.
Beppe





Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667smp

How reproducible:
Always

Steps to Reproduce:
1.Install FC on a system with Intel D915GEV mb
2.
3.
    

Additional info:
Comment 1 Giuseppe Giannuzzi 2004-11-21 10:23:38 EST
Created attachment 107135 [details]
lspci
Comment 2 Ryan Szypowski 2004-12-09 04:23:42 EST
I just wanted to toss my info in here as well.

I'm running on the same board, with a fully updated FC3 install:
kernel 2.6.9-1.681_FC3smp

For me, sound does not work (and hasn't through all FC3 tests and into
final) but network always has.  It's likely that my onboard network
can be different from other ones (the board comes in different
flavours, I believe).

For what it's worth, there are drivers at Intel's site that have been
compiled for various systems including RHEL3.
Comment 3 John Ellson 2005-03-19 09:28:23 EST
Same problem here with Intel 915G - no audio (network is OK).  
kernel-2.6.11-1.1185_FC4

lspci shows:

...
00:1b.0 Class 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High
Definition Audio Controller (rev 03)
...
06:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE
(LOM) Ethernet Controller (rev 01)

I don't know if this is related, but I see this in dmesg:

PCI: Using ACPI for IRQ routing
** PCI interrupts are no longer routed automatically.  If this
** causes a device to stop working, it is probably because the
** driver failed to call pci_enable_device().  As a temporary
** workaround, the "pci=routeirq" argument restores the old
** behavior.  If this argument makes the device work again,
** please email the output of "lspci" to bjorn.helgaas@hp.com
** so I can fix the driver.
    ACPI-1138: *** Error: Method execution failed [\MCTH] (Node df61c150),
AE_AML_BUFFER_LIMIT
    ACPI-1138: *** Error: Method execution failed [\OSFL] (Node df61c17c),
AE_AML_BUFFER_LIMIT
    ACPI-1138: *** Error: Method execution failed [\_SB_.RMEM._CRS] (Node
df622544), AE_AML_BUFFER_LIMIT
    ACPI-0158: *** Error: Method execution failed [\_SB_.RMEM._CRS] (Node
df622544), AE_AML_BUFFER_LIMIT


I tried pci=routeirq but that didn't change anything.
Comment 4 John Ellson 2005-03-21 09:45:12 EST
I just discovered that with kernel-2.6.11-1.1191_FC4 sound is actually working
on my i915g mb.  Its just that system-config-soundcard is reporting "No
soundcards were detected"

I can't tell you if this was the case with yesterdays kernel, but I could retest
if anyone is interested.

I wondered if this was just a case of the program being a little too literal
in its interpretation of a "card", but on my nvidia mb with integrated sound
it happily reports "The following audio device was detected..."

So should I report a separate bug against system-config-soundcard-1.2.10-1 ?
Comment 5 Dave Jones 2005-07-15 16:46:44 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 Giuseppe Giannuzzi 2005-07-23 05:03:59 EDT
I updated to FC4.
Audio device is detected and works fine since the first release.
I have still network controller not detected (kernel 2.6.12-1.1398_FC4smp).
Thank you.
Comment 7 Dave Jones 2005-09-30 03:25:39 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 8 Giuseppe Giannuzzi 2005-10-02 17:46:48 EDT
I'm sorry, but new kernel doesn't seems to solve the problem.
Comment 9 Dave Jones 2005-11-10 17:00:52 EST
Mass update to all FC4 bugs:

An update has been released (2.6.14-1.1637_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.

Comment 10 Giuseppe Giannuzzi 2005-11-13 03:46:24 EST
Kernel 2.6.14-1.1637_FC4 doesn't fix the problem.
Am I the only one with a such problem?
Comment 11 John W. Linville 2005-11-14 11:51:22 EST
You need the sky2 driver, which is not yet upstream and therefore not yet in 
Fedora.  I do have it as part of the test kernels here: 
 
   http://people.redhat.com/linville/kernels/fc4/ 
 
Please give that a try and post the results here...thanks! 
Comment 12 Giuseppe Giannuzzi 2005-11-15 14:24:11 EST
This is what I done:
1) downloaded and installed 2.6.14-1.1639_FC4.jwltest.23smp kernel
2) removed working device and hardware (Marvell Technology Group Ltd. 88E8050
Gigabit Ethernet Controller, driver downloaded from
http://www.syskonnect.de/syskonnect/support/driver/zip/linux and compiled on
kernel-smp-2.6.14-1.1637_FC4 kernel)
3) rebooted the system with new kernel
4) system-config-network shows 2 network hardware: the previous one and sky2
5) configuring and activating sky2 the following error occurs:
Bringing up interface eth0:  sky2 device eth0 does not seem to be present,
delaying initialization.
Comment 13 Giuseppe Giannuzzi 2005-11-15 14:24:52 EST
This is what I done:
1) downloaded and installed 2.6.14-1.1639_FC4.jwltest.23smp kernel
2) removed working device and hardware (Marvell Technology Group Ltd. 88E8050
Gigabit Ethernet Controller, driver downloaded from
http://www.syskonnect.de/syskonnect/support/driver/zip/linux and compiled on
kernel-smp-2.6.14-1.1637_FC4 kernel)
3) rebooted the system with new kernel
4) system-config-network shows 2 network hardware: the previous one and sky2
5) configuring and activating sky2 the following error occurs:
Bringing up interface eth0:  sky2 device eth0 does not seem to be present,
delaying initialization.
Thanks.
Comment 14 John W. Linville 2005-11-17 13:27:37 EST
I'm not sure what would explain that behaviour...  
  
Would you be willing to try the fedora-netdev kernels?  The driver version is  
actually the same, but there may be some other bug present in the jwltest  
kernels:  
  
   http://people.redhat.com/linville/kernels/fedora-netdev/ 
 
Please give that a try and post those results as well..thanks! 
Comment 15 Giuseppe Giannuzzi 2005-11-30 13:20:04 EST
Nothing to do ... kernel 2.6.14-1.1644_FC4 as well!
Comment 16 John W. Linville 2005-11-30 13:58:02 EST
There are several hundred patches in the fedora-netdev kernels that are not in   
the base fedora kernels.  Please do try them...thanks! (The current version is 
2.6.14-1.1644_FC4.netdev.3)  
Comment 17 Giuseppe Giannuzzi 2005-12-03 04:31:45 EST
Tried.
With 2.6.14-1.1644_FC4.netdev.3 I got the same problem but finally :-) with
2.6.14-1.1644_FC4.netdev.4 I can install and working with my network device
withou compiling drivers (no kudzu recognizing but the first step is done).

sky2 eth0: enabling interface
sky2 eth0: phy interrupt status 0x1c40 0x7d0c
sky2 eth0: Link is up at 100 Mbps, full duplex, flow control both

Do you think this patch will be include in next official kernel release?
Thanks again for your work.
Comment 18 John W. Linville 2005-12-05 10:57:49 EST
My guess is that it will take a while for sky2 to filter-in to Fedora.  But,  
I'm happy to have you as a Fedora-netdev user until then! :-) 
 
Since there is a light at the end of the tunnel, I'm going to go ahead and 
close this as UPSTREAM.  Thanks! 
Comment 19 Giuseppe Giannuzzi 2006-02-06 04:16:26 EST
John, unfortunately I noticed that last two netdev releases represent the
problem, i.e. network doesn't works! :-( What is changed? 

Comment 20 John W. Linville 2006-02-06 08:25:47 EST
The exact version of sky2 likely changed between those releases.  Perhaps one 
of those changes broke things for you? 
 
Are you saying the FC4.netdev.7 worked, but FC4.netdev.[89] don't work? 
Comment 21 Giuseppe Giannuzzi 2006-02-06 08:41:12 EST
exactly (actually I don't remember if the last one is FC4.netdev.9 or
FC4.netdev.10! It is installed on my home pc... and now I'm at work)
Comment 22 John W. Linville 2006-02-13 13:49:14 EST
Hmmm...there is no difference in the sky2 sources between FC4.netdev.7 and 
FC4.netdev.8...are you sure that is where the break occurs? 
Comment 23 Giuseppe Giannuzzi 2006-02-14 03:14:53 EST
I'm quite sure ... unfortunately I cannot confirm it because I've uninstalled
both the kernels... anyway if you need some check or confirmation I could
reinstall ;-)

Note You need to log in before you can comment on or make changes to this bug.